Solved

PPP error in RedHat 6.1

Posted on 2000-03-20
5
370 Views
Last Modified: 2010-04-20
I have a RedHat 6.1 box and am trying to get ppp working on it. I configured the interface with netcfg,(which is the way I have had the most luck with in the past). But when I try to run pppd, it gives me an error of:
"The remote system is required to authenticate itself but I couldn't find any suitable secret(password) for it to use to do so."
I am using pap, and have both a username and password, so I don't really know whats up. Any help would be greatly appreciated. Thanks,

eureeka
0
Comment
Question by:eureeka
  • 2
  • 2
5 Comments
 
LVL 1

Expert Comment

by:friebele
ID: 2638131
Use kppp. Set up as follows:
1. make sure your modem is linked properly to the correct com port. In the /dev directory there should be a link for /dev/modem to /dev/ttys0 (com1) or /dev/ttys1 (com2). If not create the link "ln -s /dev/ttys1 /dev/modem"
2. Need to remove a lock set by kppp. As root open /etc/ppp/options, and remove the word "lock".
3. Under the KDE menu open KPPP.
4. Click "device" tab and make sure device is /dev/modem, connection speed for your modem greater than one setting (ie if you have a 56K modem, set it for 115200).
5. Click "modem" tab and press "Query". This will set up your modem.
6. Press "accounts" tab. Use PAP. Enter DNS address, username and password.
0
 

Author Comment

by:eureeka
ID: 2638767
Nah, I don't want to install kde. I have done this many times before with just using netcfg, and it has worked great. I know I must be missing something. Thanks though!
0
 
LVL 3

Accepted Solution

by:
alien_life_form earned 100 total points
ID: 2641019
Greetings

put 'noauth' in /etc/ppp/options.

Cheers,
   alf

0
 

Author Comment

by:eureeka
ID: 2641689
Geeeeez, I can't believe that? This is the first time I have had that happen, and I have set ppp up on more than 20 boxes using netcfg never having to do this.

Thank you!! Your da man.

eureeka
0
 
LVL 3

Expert Comment

by:alien_life_form
ID: 2642162
Greetings.

Yep, broke all my stuff in RH 6.1.
Looks some idiot decided to switch the default (noauth) behavior to auth - and to keep it real quiet.

Cheers
      alf
 
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Anti-Spam SMTP Proxy Server (@SSP) 7 82
need to clone a white copy of a linux device 2 75
linux crontab output 3 66
Error installing extension Linux 4 58
rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now