Solved

font size in Netscape

Posted on 2000-03-21
14
325 Views
Last Modified: 2013-12-02
Hi,

I am using the netscape in RH6.1 to browser internet. However, the font size in that netscape seems very very small! can i do any thing in linux to make the font size bigger. The "Increase Font Size" in the Netscape always disable, how can i do fix it?

0
Comment
Question by:fokchi
  • 5
  • 4
  • 2
  • +2
14 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 50 total points
ID: 2640664
You can go to "Preferences>Appearance>Fonts" and set the sizes you want and even change what font is used. I always change the variable width font to Helvetica and increase the size of both fonts. To prevent html pages from futzing with my choices, I select "Use my default fonts, overriding document specified fonts".
0
 

Expert Comment

by:SVisor
ID: 2642041
Create following env. variable

"GECKO_FONT_SIZE_FACTOR 1.5"

no quotes.
0
 

Author Comment

by:fokchi
ID: 2643028
I tried what jlevie asked me to do before. But, it don't help on some of the page. The font is still very small. I want to try SVisor's solution. However, which config file I should put the variable?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2643251
If you made both changes I suggested, no html page can select a smaller font. If you only changed the size and didn't select "Use my default fonts, overriding document specified fonts", then an html page is allowed to tell the browser to use a smaller font.

If you are talking about things like parts of the netscape mail window, they are controlled by a different mechanism. I don't have the reference with me right now, but I can look it up tomorrow at work.

As to the "GECKO_FONT_SIZE_FACTOR" I'd never heard of that and can't find any evidence that Netscape knows about it either. But I did try "export GECKO_FONT_SIZE_FACTOR=1.5" and started netscape, and as I expected it didn't change anything. Try it an see if it works for you.
0
 

Author Comment

by:fokchi
ID: 2643292
thanks jlevie
0
 

Expert Comment

by:SVisor
ID: 2643866
I was so sure it would work with netscape 4.7, but it did not.

It only seems to work with Mozilla.

Sorry about that :-(

PS. I use it in "/etc/X11/xinit/xinitrc"
and the completet row is "setenv GECKO_FONT_SIZE_FACTOR 1.5" DS.
0
 
LVL 2

Expert Comment

by:mapc
ID: 2645299
if anything else fails, disable Cascading Style Sheets - helped me couple of times.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 2

Expert Comment

by:Reinier
ID: 2646200
There are a lot of sites that specify very small fonts, because they apparantly expect everybody to run 800x600 or smaller resolutions (try http://www.zdnet.com/zdnn for fun). Jlevies suggestion to "Use my default fonts, overriding......" should help there, but there is a much nicer way to solve the issue.

If you use a larger resolution than 800x600 then reverse the order of the lines

/usr/X11R6/lib/X11/fonts/75dpi/,\
/usr/X11R6/lib/X11/fonts/100dpi/

in the file /etc/X11/fs/config. Make sure the "100dpi" line comes first. Even better, also add two lines

/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,\
/usr/X11R6/lib/X11/fonts/75dpi:unscaled/

in front of the list of fontdirs. You do have the 100dpi fonts installed, don't you? Also change

default-resolutions = 75,75,100,100

to

default-resolutions = 100,100,75,75

and make sure you have

default-point-size = 120

or even larger.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2646456
Okay, If you add the following to your .Xdefaults file, it will allow you to adjust the font and/or size of those areas of Netscape. I've used Helvetica because I think it's generally more readable. You can change the font size from 120 to whatever you find pleasing. Just remember to merge in your new settings with "xdefaults -merge .Xdefaults" before you start Netscape if you're fiddling around (.Xdefaults always gets used at login).

Netscape*XmLGrid*fontList:\
-adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-iso8859-*,\
-adobe-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*=BOLD,\
-adobe-helvetica-medium-o-*-*-*-120-*-*-*-*-iso8859-*=ITALIC

Netscape*fontList:\
-adobe-helvetica-medium-r-normal-*-*-120-*-*-*-*-iso8859-*

Netscape*banner*title.fontlist:\
-adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-iso8859-*
Netscape*banner*subtitle.fontlist:\
-adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-iso8859-*
Netscape*banner*info.fontlist:\
-adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-iso8859-*

Netscape*attachItemLabel*fontList:\
-adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-iso8859-*
0
 
LVL 2

Expert Comment

by:Reinier
ID: 2648536
There are many more font related (and others as well) xresources settings for netscape. You can find them all in
/usr/doc/netscape-common-4.7/Netscape.ad. Copy any line that looks interesting from there to your ~/.Xdefaults (~/.Xresources) file and try out the differences.

0
 

Author Comment

by:fokchi
ID: 2648947
hi jlevie,

how do you merge the new settings with "xdefaults -merge .Xdefaults" in linux? I just can't find the command in my linux.

 
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2648979
Sorry, major brain fade when I typed that in, you use "xrdb -merge .Xdefaults".
0
 

Author Comment

by:fokchi
ID: 2650140
hi jlevie,

I did what you told me in my linux. now the fonts in the menu bar are big enough. However, I am sorry, I think you misunderstand my problem. I mean the font in the HTML content is too small and whenever I go the menu/view/increase font ctrl + ] or menu/view/decrease font ctrl + [. those options are always disable.  How can I active those option or make my default font in html bigger?

Sorry about the misunderstanding. It all because I did stated my question clearly. Still hope you can help me whit this, cause I really have problem to netvigate the net in Netscape.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2650452
I think that those controls are either simply disabled or only work if the html page you are viewing uses Dynamic Fonts.

If you want the fonts to be bigger, go back to my original comment and make those changes to your preferences.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now