Solved

Mouse Problem in Red Hat 5.2

Posted on 2000-03-21
5
169 Views
Last Modified: 2013-12-06
I'm using Red Hat Linux 5.2 and a logitech mouse. When I run mouseconfig I seleted generic 3 button ps/2 mouse. There are some logitech mouse options like Mouseman/Firstmouse + but I did'nt choose them because the mouse I have dose'nt say that.
When I restart the pc and go into X Windows using the Start X command, the mouse " seems " to be there, but it keeps jumping to the top left hand conner of the screen. When I move the mouse around, the cursor moves, shoving that there is some kind of response, but just keeps going back to that samn conner. I cant dont anything. I tried changing to a genius mouse, but that was worse.

Any suggestions ?
0
Comment
Question by:Kelvin_King
  • 3
  • 2
5 Comments
 
LVL 13

Author Comment

by:Kelvin_King
ID: 2644218
Adjusted points from 50 to 200
0
 
LVL 2

Accepted Solution

by:
mapc earned 200 total points
ID: 2644299
If your mouse works in text mode:
e.g. start gpm with the type ps2 and right port, and try the three buttons.
If it worked, then, run it next time with -R switch- it creates pipe in /dev/
(check it's name from manpage)
and then, in XF86Config choose this device as a mouse pointer and choose protocol "Mouse Systems" for it, since gpm emulates it on that /dev/.. entry.
If not, try to figure out how to make it work in text mode, and then go back to what I proposed.
Hope that it helps.
0
 
LVL 13

Author Comment

by:Kelvin_King
ID: 2645131
I can see the mouse curser in text mode ( I'm assuming u mean the dos like interface ) where do I run gpm from ? what is gpm ?
0
 
LVL 2

Expert Comment

by:mapc
ID: 2645176
ok, if you see the mouse pointer in terminal mode, then, clicking the left button and holding and dragging should mark text. the middle button should "paste" what you've selected, and the right button should set mark without holding the mouse.
I hope that I explained it well.
If it works fine, just like I explained, then go with my solution.
If not, try to play with gpm flags.
ps ax should show gpm running
it's started from /etc/rc.d/rc3.d/??gpm I guess.
0
 
LVL 13

Author Comment

by:Kelvin_King
ID: 2648666
Good Stuff, it works !!
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now