Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

my perl cgi just do not work in IIS pls pls help me

Posted on 2000-03-22
5
Medium Priority
?
256 Views
Last Modified: 2013-12-25
Can you describe to me what are the step to configure IIS to work with Perl CGI. This is really driving me mad.

pls pls help me
0
Comment
Question by:da511
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 

Expert Comment

by:venky75
ID: 2643789
Hi there,

It's very simple. All u have to do is
right click on properties tab of the server available on IIS. In Master properties edit the WWW settings. Now click on the "Home Directory" tab on top. Click the "Configuration" button.

A window opens up. Use the tab on top "Add Executables" . Now click on the Add button. A small window opens this time. Now enter the path leading to the Location of perl.exe on the m/c. in Executable field. followed by
a space and %s%s. Then give the entry in extension field as .pl or .cgi as the file may be. That's all ur perl configurtation is done. Apply the settings and restart the IIS.

Hope this'll help u out.

Bye
venky
0
 
LVL 2

Author Comment

by:da511
ID: 2643849
I got the following errors

<HTML><HEAD><TITLE>Internal Error</TITLE></HEAD>
<BODY>
<H1>Error in /cgi-bin/Scart_Viewer.exe</H1>
The following internal error has occurred:
<PRE>Component 'MSADODC.OCX' or one of its dependencies not correctly registered: a file is missing or invalid Error Number =  339</PRE>
<I>Please</I> note what you were doing when this problem occurred,
so we can identify and correct it. Write down the Web page you were
using, any data you may have entered into a form or search box,
and anything else that may help us duplicate the problem.
Then contact the administrator of this service:
<A HREF="mailto:YourEmailAddress@Here">
<ADDRESS>&lt;YourEmailAddress@Here&gt;</ADDRESS></A>
</BODY></HTML>
0
 
LVL 2

Author Comment

by:da511
ID: 2643951
I had follow your steps but still doesn't work
0
 
LVL 10

Accepted Solution

by:
makerp earned 400 total points
ID: 2643993
this is cut from another question i have answered

to install/configure perl in iis do this.. its easy    

if your on winNT then download activeperl. it makes for such an easy life. http://www.activestate.com 

to enable a dir to allow execute access:

all you have to do is set the directory that you want to exe in to execute rights from within the microsoft managment consolue or using pws managemnt thingie. DO NOT set that dir to write access as well, if you try mmc will warn you of security probs.
to do this select properties on the dir in question (cgi-bin if you like) and then selet execute on the directory tab. this can be at virtual dir level of a dir underneath this.


setting up perl.exe:

when you install activeperl it sets up the .pl link to the perl exe for you. if your not using activeperl or you installed active perl after iis then you need to go to mmc/default web site/ properties/home directory and then click on the configuration option. a window will appear with all of your exention mappings in. add one for .pl

extension - .pl
executaable - <DRIVE:>\<perl path>\perl.exe %s %s
method exclusions - PUT,DELETE

by doing this at the web site level these settings will stand for all virtual dirs unless you specify other wise.

if its a perl script you want to run then leave the .pl extension, put the script in the dir with exe rights and your off !!

IIS also supports the use of a perliis.dll mapping to a .plx extension. im not sure but i think this is microsofts awnser top mod_perl. dont quote me on this though as ive never had the need to use it...

because iis does the perl thing on the extension you don not need #! perl path at the beging of you script.  if you do it will be ignored ..

to run a standard .exe then the dir permissisions need to be execute

hope this is what you want ?
0
 
LVL 10

Expert Comment

by:makerp
ID: 2643997
the error you are getting is internal to the .exe you are trying to run NOT IIS
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Making a simple AJAX shopping cart Couple years ago I made my first shopping cart, I used iframe and JavaScript, it was very good at that time, there were no sessions or AJAX, I used cookies on clients machine. Today we have more advanced techno…
In this tutorial I will show you how to provide a dynamic RTF document on your website generated with data from your database. For this tutorial you will need Microsoft Word or WordPad, WhizBase and Microsoft Access. In this tutorial I will show …
The viewer will learn how to count occurrences of each item in an array.
In this fourth video of the Xpdf series, we discuss and demonstrate the PDFinfo utility, which retrieves the contents of a PDF's Info Dictionary, as well as some other information, including the page count. We show how to isolate the page count in a…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question