Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Sendmail to Queue as Default

Posted on 2000-03-22
6
Medium Priority
?
352 Views
Last Modified: 2010-04-20
I'd like my sendmail to queue the messages sent through it by default, so it wouldn't try to send them immediatelly. my /etc/ppp/ip-up script would then run sendmail -q to make it finally deliver the messages.

 Question: How do I set up sendmail so it would not try to deliver the messages immediatelly and queue them instead?
0
Comment
Question by:EatEmAndSmile
  • 3
  • 2
6 Comments
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 2646816
Used linuxconf and then mark this option ind sendmail conf file.
0
 
LVL 2

Author Comment

by:EatEmAndSmile
ID: 2648695
Man, I'm talking about LINUX here, not RedHat. Please don't lock my question with an answer so others can try to solve my problem, ok?

 Thanks.
0
 
LVL 4

Accepted Solution

by:
kiffney earned 200 total points
ID: 2649590
Try

DeliveryMode=delay

in the sendmail.cf file.  If you're using dial-on-demand ppp link, also do

DialDelay=10s

to allow sendmail time to connect.  I think this requires at least sendmail 8.7.  

For a lot more tips on this topic, try
http://www.harker.com/sendmail/smtpdemanddial.html.
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
LVL 2

Author Comment

by:EatEmAndSmile
ID: 2650406
Thanks a lot.

 Actually I'm using 8.9 and it works perfectly with Demand Dialing. It waits until the connection is stabilished (as most of the applications that work with DD) and then does it's job without a glitch.

 The only proggie I see that doesn't work properly with DD is ftp. It doesn't wake up when the connection is stabilished and remains waiting for a connection forever, until the DD idle time times out and the connection is dropped.
0
 
LVL 2

Author Comment

by:EatEmAndSmile
ID: 2650411
Text above.
0
 
LVL 4

Expert Comment

by:kiffney
ID: 2650783
If you do

echo 1 > /proc/sys/net/ipv4/ip_dynaddr

that might help with the ftp timeouts.  It used to help with diald - don't know if that trick still works with the demand-dial built into pppd.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month21 days, left to enroll

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question