Samba making me nuts

I installed Samba fine.  I configured a group admincdr with my user name in it.  I created a shared directory called [admincdr] with validated users admincdr.  I can see the Samba Server when I go to Network Neighborhood from any Windows PC on the network.  But when I click on the icon it asks me for a password. (Resource: \\SAMBA\IPC$) I enter all the possible passwords that I have programmed in the linux box but it does not allow me to connect.  When I try from another PC it asks me for a username and password.  I enter a valid username and password and it does not like it!  What should I do?
wchanceAsked:
Who is Participating?
 
intheConnect With a Mentor Commented:
hi,
i found this that should help you:
Windows 98 is not able, per default, to negociate or to accept an authentication based on plain-text passwords. And per default, Samba will only send clear-text passwords. So you will have to add the following in you smb.conf file, global section to tell Samba also to use encrypted password. :
      encrypt passwords = Yes
This is one thing, the other is the creation of the encrypted password.       1) You must have a linux username identical to the one you are using in Windows. (I think is already the case).
      2) Create the encrypted password for this user : smbpasswd -a <USERNAME>. This will create a file called smbpasswd under a directory called private. If you want to change the location of this directory use the following line in your smb.conf file, global section :
          smb passwd file = /<PATH>/<TO>/<FILENAME>
 
This is needed with the security=user or with the security=share. (This is a line of the global section of the smb.conf file). This two methods of security use both a password exchange so it need to be encrypted.
 
Another solution is to allowed windows98 to use plain-text passwords. This is done by adding a registry key on your windows (the type of the key is DWORD) :
 
Path to key : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VNETSUP Name        : EnablePlainTextPassword
Value      : 00000001
 


Regards Barry

0
 
intheCommented:
ps:
you will find better explanantions here:

http://home.germany.net/101-69082/samba.html#4.4.
0
 
bcolemanCommented:
Instead of using valid users = admincdr, use valid users = <your username>
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
castleinfoCommented:
The easy way is to configure samba to make files available as a SHARE not per USER.

This will at least give you the confidence to move on to setting up an encrypted password file etc as in the instructions... It took me a week or so to figure out but once it works it's seemles and doesn't prompt for passwords.
0
 
wchanceAuthor Commented:
Adjusted points from 100 to 125
0
 
wchanceAuthor Commented:
He guys it worked, the only problem is that it is very slow.  I tried to transfer a 57 meg file and it said it would take an hour.  I copied it from a Windows to Windows and it took 2 minutes.  Please let me know what I have to fine tune.

0
 
intheCommented:
cant help much there but it is certainly a common problem..
pastye the whole link below into your browser window for a listing of other people who have/had same problem:

http://www.deja.com/dnquery.xp?ST=MS&QRY=samba+linux+windows+file+transfer+slow&svcclass=dnserver&DBS=1
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.