Out of stream resource...SCO UNIX error

I have a SCO Openserver 5.0.5 enterprise server with 250 sco user licenses running an infomrix IDW Workgroup server via TCP-IP.  Whenever my pseudo terminal count of users exceeds 100 I get the following error in the syslog "inetd[322]: accept: (for telnet) Out of stream resourc".  I have verified that my 250 sco users licenses are installed and I run the netstat -m command and by streams, queues, and message blocks all still have plenty of free allocations, my streams memory is as follows:

total configured streams memory : 5072.00KB

streams memory in use: 1322.00KB
maximum streams memory used: 1633.80KB

Could someone give me insight as to what is causing this error to come up and effecting users after user count is 100 or 101?


r_hortonAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
gurumaartenConnect With a Mentor Commented:
ofcourse i meant NPROC instead of NPROX...
0
 
sparks1970Commented:
When you did netstat -m did anything appear in the 'fail' column?  

Also, using configure, what your NSTREAM value.  You might consider bumping that up.

0
 
philiph_elvisCommented:
NSTREAMS is auto-tuned on OpenServer 5.0.2 and above, so you shouldn't have to mess with that setting.  Checking netstat -m is still a good place to start.

Also, with all SCO questions, you should first search the SCO Technical Articles, located at http://www.sco.com/support.  A search on your error message could very likely show a supplement which fixes the problem.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
fbjeanCommented:
Just asking, how many pseudo-tty are define in your SCO ?
Go in scoadmin,kernel configuration and check the number of pseudo-tty.
In a standard installation it will never exceed 100 but you can add as many as you want.
0
 
jacquesc030600Commented:
Would you try that;

first increase you pseudo tty

second

# cd /etc/conf/cf.d

# ./configure

choose STREAM

and increase the number of stream


Relink the kernel

reboot the computer
0
 
r_hortonAuthor Commented:
As I reported with my netstat -m... the available streams,mblks, and queues still are in the 3000 or higher that are still available.  So uping the streams is not the answer.  My streams are already set at 7500 with about 4000 free.  I stated this in my original quetsion.  My psuedo tty is set to 650 as well.
0
 
gurumaartenCommented:
Can you give the values for NPROX & MAXUP? Perhaps you can show some params from the files /etc/conf/cf.d/stune & mtune??
0
All Courses

From novice to tech pro — start learning today.