Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

HP Deskjet 660C Communication Probs

Posted on 2000-03-26
8
Medium Priority
?
291 Views
Last Modified: 2013-12-15
I'm trying to install a HP 660C onto my system (running '95) and keep coming up with 'its not communicating with the computer. I've installed two different types of drivers, dj6609x and dj149en and still get no luck. There are no conflicts I can find, my other printer works fine off both sets of cables (its a laser NEC silentwriter). I think I've done all the basics.
Any ideas?
0
Comment
Question by:Cassandra033099
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 5

Expert Comment

by:bparnes
ID: 2659412
Here are some suggestion for what to do next. First make sure that you have an IEEE 1284 compliant printer cable.

Next, run some self tests on the printer to make sure it works on its own:
To run a self-test
  Turn the printer on.
  Press and hold the Resume button until the printer starts printing. Release the Resume button.

To run a clean-test
  Turn the printer on.
  Press and hold the Power button, press the Resume button seven times, and then release the Power button.

To run a diagnostic-test
Regular
  Turn the printer on.
  Press and hold the Power button, press the Resume button five times, and then release the Power button.

Extended
  Turn the printer on.
  Press and hold the Power button, press the Resume button twelve times, and then release the Power button.


Use your CMOS BIOS setup program to change the configuration of the parallel port. You will want to test ECP and EPP settings.


0
 

Author Comment

by:Cassandra033099
ID: 2660079
Adjusted points from 800 to 1000
0
 

Author Comment

by:Cassandra033099
ID: 2660080
I'd done all this, changed drivers, tried to change it to a unidirectional communication mode and still get no response. The printer was working on another system prior to my getting it. (The cable came with the printer)
The port was the same one I was using for my other (laser) printer which it was communicating with fine. One of the error msges comes up as parameters for the port being incorrect. (?)
How do I get into the cmos bios settings to change the port settings then?
I've done all the other basic troubleshooting you'd reasonably expect to have done. Got any other ideas?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 21

Accepted Solution

by:
briancassin earned 4000 total points
ID: 2662097
You have got two probs that i would say right off the bat


1. You need to get into your bios and try the different parallel port modes i.e. spp, ecp, epp. the way to get into your bios is when the pc boots up it will say press this key to enter setup press that key it will take you into your bios you will want to look under intergrated perphrials or ports section and look for the parallel port try one of the modes such as spp then save the change reboot and see if it helps.


2. The nec printer you have has a status monitor it will need to be uninstalled there should be an uninstaller either in add/remove programs in your control panel   or on your start, programs menu if it is not listed in either then the only way to get rid opf it is to go to start settings printers right click on the printer and select delete....When it asks if you want to delete all the files say yes...

However the last method will leave bits and pieces behind of the printer that may have to be removed from your system files

I would try this also

Go to start shutdown restart in msdos mode at the c:\windows prompt type DIR>LPT1 and hit enter it should print out if you get an error message please post it here

make sure you have the printer attached directly to the port no switchboxes or pass through devices such as other printers, scanners, tape backup drives
0
 
LVL 21

Expert Comment

by:briancassin
ID: 2662106
here is the url of some good troubleshooting methods....

http://www.officejetsupport.com/oj700/faq/bpu01215.htm 


i was involved in another question with a NEC previously being on the system and they could not get there officejet 710 to communicate at all on that same pc.
0
 
LVL 3

Expert Comment

by:vikiing
ID: 2663299
Most HP printers show the same behaviour. The solution I could find for a client (perhaps it's not applicable to you) was to set the port at BIOS as the simplest SP mode, this is.

¿How do you change that? When you turn on the machine, press Del key to enter into BIOS setup. Once there, check for "Peripheral devices" option (or something like that). Then, change parallel port to SP, save change into CMOS memory, reboot and try to see what happens.
0
 

Author Comment

by:Cassandra033099
ID: 2664720
I can't thank you enough! After asking several people, your help was invaluable. I completely uninstalled the NEC and removed the system files, then I changed the BIOS settings to PS/2 Bidirectional and voila, there it went. :-)
Thank you for all your help.
0
 
LVL 21

Expert Comment

by:briancassin
ID: 2664868
your welcome cassandra :)  
Glad you were able to get rid of the NEC I have seen some people have to format there systems to get rid of NEc printers because they do not use the standard naming convention of naming there files like there company name i.e. nec.386   or nec356.dll as an exmaple instead the name it something completely obscure.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you use a Brother DCP 130C or similar Brother printer, at some point you might encounter the following problem: after you change the ink cartridge, the printer displays an "ink empty" message. Sometimes you just need to follow the instructions…
How to solve seemingly unsolvable printer issues. Users sometimes run into printing issues where all the normal steps do not seem to work. Well the steps below can show users how to take one extra step beyond the normal steps needed to remove old…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question