Linux won't recognize my modem

I just installed a new creative labs modem blaster in my machine.  when I attempted to query the modem in KPPP, I get the message:

Sorry, modem busy.

This modem is not a winmodem.

Any suggestions?
LVL 1
wilch101Asked:
Who is Participating?
 
Ted22Connect With a Mentor Commented:
I have a pnp modem. I assume this is also. I set my bios up to auto-configure
pnp devices. No pnp os installed and autoconfig. Otherwise you must use pnpdump > /etc/isapnp.conf and configure isapnp.conf. Then I added this line to /etc/rc.d/rc.local. setserial -b /dev/modem auto_irq skip_test auto_config. Dev modem would be whatever dev your modem is. It's much easier just to let your bios set it up and it's there!
0
 
jlevieCommented:
Are you talking about the "Modem Blaster Flash 56II" or one of the others? If it's the 56II, when you installed it what IRQ & IO did you use, and is it conflicting with an on-board serial port?
0
 
EatEmAndSmileCommented:
Man, I'm sorry to tell you any Creative Labs modem is definitelly a winmodem. Unless you've got a rare hybrid model.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
EatEmAndSmileCommented:
Oh, I almost forgot... kppp is not a good software for testing your modem. Use minicom, as it's the best terminal software there is. Just type minicom -s /dev/modem. Make sure the /dev/modem link was set correctly, aswell...
0
 
dbusherCommented:
wilch101,
1. From the control panel use the network configurator (icon with several pc's networked together) to create an ppp interface (i.e. ppp0). (Be sure the Line speed is correct and the Modem Port option is set to the correct device (i.e. /dev/modem or /dev/ttyS0). If you are not sure where your modem is you can use the command statserial at the command prompt.  You can use modemtool to link the ttyS# to the modem device). Under the 'Communications' section fill in init string of ATZ, Dial command of ATDT and then a phone number.
2. At an terminal window type /sbin/ifup ppp0   (or ppp# whatever you interface number is).  You should hear the modem pickup.  If not then look in /var/log/messages file for clues.
Hope this helps.
0
 
wilch101Author Commented:
Ted22's comment answer helped.  My bios would not automatically set it up, but using his method, I was able to manually enter the settings into the rc.local file.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.