Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 410
  • Last Modified:

compiler option -mpreferred-stack-boundary=2 problems

When I try to make my Kernal the compiler barfs at a known option. Here's the nohup.out from "make xconfig" in directory /usr/src/linux:

rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts kconfig.tk
make[1]: Entering directory `/usr/src/linux-2.2.13/scripts'
gcc -O6 -fomit-frame-pointer -fno-exceptions -fno-rtti -pipe -s -mpentium -mcpu=pentium -march=pentium -ffast-math -fexpensive-optimizations -malign-loops=2 -malign-jumps=2 -malign-functions=2 -mpreferred-stack-boundary=2 -c -o tkparse.o tkparse.c
cc1: Invalid option `preferred-stack-boundary=2'
make[1]: *** [tkparse.o] Error 1
make[1]: Leaving directory `/usr/src/linux-2.2.13/scripts'
make: *** [xconfig] Error 2

Help! GNU's manual for gcc says that this option is fine. What's wrong? Is there a variable that should be set?
0
jnalexander
Asked:
jnalexander
  • 4
  • 3
  • 3
1 Solution
 
kiffneyCommented:
Do 'gcc -v'.  The preferred-stack-option doesn't work with gcc < 2.95.  Your manual may not be the right one for the version of gcc you're using.
0
 
jnalexanderAuthor Commented:
Yeah, I have version 2.91.66. But I got the makefile, libraries and compiler from the same CDROM. Why would they use a different version of the compiler to build my kernal than the one they included on the CD?

How do I fix this problem. Do I download the latest gcc package or edit the makefile and remove the option?
0
 
hotbotCommented:
hello , try to edit the Makefile and remove the invalid option (backup your original Makefile first)
0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
kiffneyCommented:
Whoever put together your distribution probably just made a booboo.  I'd get the latest gcc package and install it rather than futzing with the makefile - the preferred-stack-option might be important (or not - but a newer gcc is probably better anyway).
0
 
jnalexanderAuthor Commented:
I tried to use the latest version of gcc but kpackage complained that there were "conflicts" during installation
0
 
kiffneyCommented:
does kpackage run rpm?  You could try running it from an xterm and do --force --nodeps, or at least see what rpm doesn't like about the package - maybe there's something else that needs to be installed first -
0
 
jnalexanderAuthor Commented:
It turns out that hotbot had the correct idea after all. (Sorry hotbot!) http://mandrakeuser.org has a perl script that removes the "preferred-stack-boundary=2 option from the Makefiles.
0
 
hotbotCommented:
if i know you have , mandrake i never help you , but that's ok :)
0
 
hotbotCommented:
if i know you have , mandrake i never help you , but that's ok :)
0
 
hotbotCommented:
sorry for the repeating i don't know how i do that's , i'm newuser of this help system , i don't think i be a day an old one :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now