[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 237
  • Last Modified:

Restart NT. / login

I`m Trying to Restart NT

1)

I get ERROR_ACCESS_DENIED Error.

When Call to:
InitiateSystemShutdown(NULL,NULL,0,TRUE,TRUE)

I`m logged as a member of Administrators Group on this machine.

2)  
  Is it possible to restart the computer in the way that it will not prompt for user and password.

(I want to run automaticaly a program that is in Windows 'StartUp' after restart,
but the problem is that it will not run it till somebody will enter a login/password.)



===========

 
   
 
0
TelMic
Asked:
TelMic
1 Solution
 
cbeattieCommented:
TelMic, in order to shutdown windows, use the following function call instead of InitiateSystemShutdown:

1)
ExitWindowsEx(
  UINT uFlags,       // shutdown operation
  NULL   // reserved
);

For the uFlags parameter use one of the following values:
EWX_LOGOFF // Return to login screen
EWX_POWEROFF // logout & powerdown (system must support power-off)
EWX_REBOOT // Logout & Reboot
EWX_SHUTDOWN // Logout to the "Safe to turn off power" screen

I'm not sure how to do #2.  If this works, let me know and I'll resubmit as an answer.
0
 
pagladasuCommented:
You can enable automatic logon. Follow these steps:

1.Start regedit.exe (Start - Run - regedit)
2.Open the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon
3.Double click the DefaultDomainName and fill in your domain name
4.Double click the DefaultUserName and fill in login name
5.From Edit menu select New String Value, and enter DefaultPassword as name of value
6.Double click the DefaultPassword and enter in the password
7.From Edit menu select New String Value, and enter AutoAdminLogon as name of value
8.Double click the AutoAdminLogon and set the value to the number 1
9.Close regedit
10.Logoff and you will be automatically logged in again
0
 
TelMicAuthor Commented:
cbeattie,

I got an error (using GetLastError)

1314 A required privilege is not held by the client.  ERROR_PRIVILEGE_NOT_HELD
0
 
cbeattieCommented:
TelMic,

Which flag did you use?  When you got the error?  EWX_POWEROFF, EWX_REBOOT, and EWX_SHUTDOWN require the user to have the SE_SHUTDOWN_NAME privilege, but only if running under Windows NT.

If you use EWX_LOGOFF, you shouldn't get any Privilege errors.  Also, make sure you pass in 0 for the second parameter.

If you want to use one of the other three options, you must first make a call to AdujstTokenPrivileges() to enable the SE_SHUTDOWN_NAME privilege, although I've never run into this situation before.  If you need assistance with this function, let me know and I'll be happy to help out.
0
 
Sasha_MapaCommented:
cbeattie,

I`m working on Windows NT,

Yes Please Help me with the AdjustTokenPrivileges();

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now