• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 417
  • Last Modified:

eth0 startup options

How do I supply a command-line option to the startup network scripts for the eth0 interface?  What I'm trying to do it have eth0 come up with "txqueuelen=35" instead of the default setting of 100.

Any ideas?
0
pogga
Asked:
pogga
1 Solution
 
kiffneyCommented:
You should be able to just add a line  to /etc/conf.modules saying

options eth0 txqueuelen=35
0
 
poggaAuthor Commented:
That didn't work.  In fact that screws things up!!!
0
 
kiffneyCommented:
The way you figure out these things is by reporting the EXACT error message you saw when it 'didn't work', what it screws up and what happens that tells you it screws up.  You might also chip in with what ethernet driver you are  using and how you were doing it manually.  
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
poggaAuthor Commented:
I screws up because the eth0 card comes up with txqueuelen=100 (default) and I've noticed that I have no network access what-so-ever. I check my routing table and its as it should be. I checked (using ifconfig) eth0 and everything appears ok.

Any other ideas I should try?
0
 
kiffneyCommented:
You still didn't mention which ethernet driver you use.  If you installed the kernel source, you could look in /usr/src/linux/Documentation/network, find the type of driver you're using, and check the .txt file to see if that's a valid option - that, or the source for the driver in /usr/src/linux/drivers/net.  What driver is being loaded?  'lsmod' will tell you if it's a module.  Also post the contents of ifconfig with and without th option - also look through the output of 'dmesg' for info  about the ethernet card and any messages that appear when it's loaded.
0
 
SokkaCommented:
When U install linux it will ask you for option for any parameters to pass. Eighther u can give there

or


U can give it in LILO boot
0
 
poggaAuthor Commented:
I may be wrong but lilo boot is not a place I'm gonna start throwing parameters at!
This is simply the network card I want to tweak, can I do this at the lilo prompt? (Apologies if I sound sceptical.)

Yes, you're correct. I could (and should) have entered the eth0 options at install time.  However, this is a development server and I cant just re-install 'cos I wanna tweak the network card.

Keep the help coming ...
0
 
poggaAuthor Commented:
Adjusted points from 100 to 150
0
 
kiffneyCommented:
OK, I finally understand your question.  I was thinking the txqueulen parameter was some driver parameter that you set with the module that drives your network card, when in fact it's set by 'ifconfig'.  All you need to do then (if you're using a  RedHat-like linux) is edit /etc/rc.d/rc.local and at the end of that file add the line

ifconfig eth0 txqueulen 35

since by that time the eth0 device will be up.   There is an if-up script in /sbin on redhat systems that you would think could handle this, but it looks to me like it won't.  
0
 
roundstCommented:
could you not put the options into the appropriate box in 'kernelcfg'?
0
 
poggaAuthor Commented:
That looks like the place to put it.
Thanks for the help everyone.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now