Solved

Getting IP address in W2K

Posted on 2000-03-30
4
138 Views
Last Modified: 2010-04-13
I have a laptop that is a DHCP client for my modem connections as well as my LAN connections.  When I'm in the office and I boot up, I get an IP address from our company DHCP server.  When I go into hibernate mode, go home and dial into my ISP, I get a different IP address that allows me to surf the net.  I put it back into hibernation mode and go back to the office and connect to the LAN once again.  But this time, I don't get an IP address from DHCP.  Instead, I get an automatic IP address from I don't know where.  I try to release it and it won't let me.  I try to renew it, and it won't let me.  The only way I can get a LAN IP address again is to reboot.  Microsoft touts the ability of never having to reboot even when moving from network to network.  I haven't found that to be true at all.  Any ideas on how I can get an IP address from the DHCP server without having to reboot?
0
Comment
Question by:sirsly
  • 2
4 Comments
 

Expert Comment

by:Prevost
ID: 2672162
What process did you go through to renew it?  I've been able to get entirely new DHCP leases by going to Start Menu:Settings:Network and Dialup Connections, disabling the active connection then enabling it again.  Of course, I wasn't throwing in Dial-up IP in there at the same time -- just hopping from LAN to LAN.

Prevost
0
 

Author Comment

by:sirsly
ID: 2673995
I used IPCONFIG /RELEASE and it told me that it couldn't release an autotmatic IP address.  I even tried IPCONFIG /RENEW and it told me a DHCP server could not be contacted.
0
 

Accepted Solution

by:
pfie earned 50 total points
ID: 2708378
There are several points that may be misunderstood in your question, so í propose several possible solutions.

First when connecting to the Lan and when connecting to internet at home by modem you refer to different adapters, which appear as different objects when typing ipconfig /all. When typing ipconfig /release you try to release the adresses for both adapters. Every adapter gets a separate IP Adress bound to it upon connection.

If you want to release the ipadress of your Lan adapter type ipconfig /release [adapter] using the [(Lan)adapter] as it is displayed in ipconfig /all.

It is possible that he trys to release the config on virtual adapter representing your modem, and its rather clear he can not find a dhcp server there at this time. (It is not clear if hybernation mode does clear this connection)

Also the ipconfig /renew [adapter] should be used on the Lan adapter, if the modem connection is not properly cleared after hybernation.

The ipconfig /release command may also be dependent on your users rights, and that may cause that you are not allowed to change the ipadress. So try it with administrator rights, to check if thats the cause of the problem.

But there is a third possible cause that may fit in, from your discription: there is a known bug, that causes the workstation to freeze when typing ipconfig /release. It occurs if you upgraded the machine to win2k, but an earlier version than 1.2 of the network manager is installed, and was not properly upgraded. In this case you have to uninstall the NMagent service, and install the network monitor 2.0.

hm.. another idea i came to think of is that you may have cached wrong ip-adresses for your DHCP Server during the connect at home (or job). As hybernation mode may conserve this cache. ipconfig /registerdns should flash that cache.

Hope that helps
Rgds
petra
0
 

Author Comment

by:sirsly
ID: 2713487
Let me try to describe my scenario a little better.  When I'm in the office on a LAN connection, I have no problem getting an IP address to my LAN card.  I go into hibernation mode.  I then disconnect from the network and go home.  From home, I dial into an ISP and my Modem gets an IP address.  When I'm finished with the ISP, I "hang up" my connection then go into hibernate mode.  I go back to the office the next day and reconnect to the network.  I don't get an IP address anymore.  I tried releasing and renewing (I didn't try specifying the LAN card in my syntax).  I still didn't get an IP address (Since I installed and configured W2K, I made sure that my account is a member of the Administrators group).  The only thing that SOMETIMES works is if I Disable the LAN connection and then Enable it again.  That seems to work sometimes, but not all the time.  I will try releasing and renewing again with my LAN card specified.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now