Solved

load balancing question!

Posted on 2000-04-02
3
263 Views
Last Modified: 2010-04-12
Dear Experts,
Here's the config simulating a customer has two leased to ISP and using one
as back up. I used the Cisco 4000 to simulate our backend router and
connect two 805 as the customer routers.
(This config only works when two line are conneISPng to ISP)


4000------805-1---
 I                + hub--PC
 I--------805-2---
Config the PC's gateway to 805-1 's e0 port. Here's the configure of 805-1:
1#sh ru
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 1
!
no logging console
enable password ISP
!
username root password 0 ISP
ip subnet-zero
!
!
!
process-max-time 200
!
interface Ethernet0
ip address 192.168.0.253 255.255.255.0
no ip redirects
no ip directed-broadcast
!
interface Serial0
ip address 10.0.0.2 255.255.255.0
no ip directed-broadcast
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip route 0.0.0.0 0.0.0.0 192.168.0.254 50
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login local
!
end
The backup link is 805-2, here's the configure:
2#sh ru
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2
!
no logging console
enable password ISP
!
username root password 0 ISP
ip subnet-zero
!
!
!
process-max-time 200
!
interface Ethernet0
ip address 192.168.0.254 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 10.0.1.2 255.255.255.0
no ip directed-broadcast
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.1.1
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login local
!
end
2#
In the Cisco 4000, add two routes to the two links:
ip route 192.168.0.0 255.255.255.0 10.0.0.2
ip route 192.168.0.0 255.255.255.0 10.0.1.2 50 <----- backup link (has metric 50)
Notes:
- The technique is "floating static route". The route with a greater metric does not appear
in the routing table normally. But when the main link fail, then the backup route will appear.
- You need to use "no ip redirects" in the e0 of the 805-1 router to disable ICMP redirect
message . Otherwise when the main fail link recovered, the PC will still using 805-2 to
transmit packet, due to the ICMP redirect message send by 805-1.



Further study:
Any expert advise me how to do load balancing without using any dynamic routing protocol in this case, what the commands?

Thanks a lot!
0
Comment
Question by:qps
  • 2
3 Comments
 
LVL 1

Expert Comment

by:dserna
ID: 2680153
I just have a question for you, which way would you like to load balance the traffic? From the 4000 to the two 805's or from the two 805's to the 4000, or both WAYS?
0
 
LVL 1

Accepted Solution

by:
dserna earned 200 total points
ID: 2681015
Now that I re-read your question, it seems that you only need to know how to balance traffic from the 4000 to the 805's:

To load-balance the traffic that comes from the 4000 to the 805's you simply take away the metric of 50:

change from this:


In the Cisco 4000, add two routes to the two links:
ip route 192.168.0.0 255.255.255.0 10.0.0.2
ip route 192.168.0.0 255.255.255.0 10.0.1.2 50 <----- backup link (has metric 50)


change to this:

ip route 192.168.0.0 255.255.255.0 10.0.0.2
ip route 192.168.0.0 255.255.255.0 10.0.1.2


The above tells the 4000 router that there are two paths to the 192.168.0.0/24 network, one is through 10.0.1.2/24 and the other is through 10.0.0.2/24, more importantly, it tells the router that they have the same cost of 1. By default, static routes that exit via an attached interface have a cost of 0, static routes that are next-hop have a cost of 1. The router will then evenly distribute the traffic between those static routes.
0
 

Expert Comment

by:kachan
ID: 2763545
I think more reliably, you should consider OSPF and let OSPF to determinate which route that it should use.
0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Add Mac address reservation to Sonicwall TZ 210 router 1 62
Expanding Subnet Mask 20 158
ospf neighbors not coming up 6 60
Configure BGP 22 14
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question