• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 158
  • Last Modified:

CSS Question

I have a CSS file that applys settings for a table...

It looks great in Internet Explorer, but netscape ignores some of the tags...  

The simplified table and CSS can be found here.
www.coopa.demon.co.uk/ee/test.htm
www.coopa.demon.co.uk/ee/test.css

The Question is...  
How can I alter the CSS file so that this table appears fine in netscape ?
Does Netscape support all of these css features ?
Is there another method ?

Help please...

400 points for anyone who can completely solve this.
0
coopa
Asked:
coopa
1 Solution
 
tzaradCommented:
You have to add the following line in your css

TD {
      FONT-FAMILY: arial, helvetica, swiss, sans-serif; FONT-SIZE: 7pt; FONT-WEIGHT: bold
}

The first line :120 will still be out of size because you forgot to close the </td>

Hope it helps
Qapla'

0
 
coopaAuthor Commented:
Okay...  half way there...

But why is netscape ignoreing the stuff under the <TH> tag ?

th {
color = white;
background-color = #004080;
font-family: arial, helvetica, swiss, sans-serif;
font-weight: bold;
font-size: 7pt;
}
0
 
damianoskyCommented:
Netscape supports only a limited version of CSS1, while explorer supports both CSS1 and CSS2.

What you are experiencing is only one of the variuos strange behaviours Netscape has regarding CSS.

Regarding font type, this is one of the problems. For example, if you redefine the font layout-type for the tag <p>, if you use within a <b> tag, this is not applied: you must redefine also the <b> tag to get the right formatting.

Strange, but is true...

If you need font control, i suggest you to try this: define a style class like this example:

<style>
<!--
..my_font_class { font-family: arial, elvetica, swiss, sans-serif; font-weight: bold; font-size: 7pt }
//-->
</style>

and then apply it to your text in this way:

<font class="my_font_class">your text</font>

It's not so flexible, but this way should guarantee you similar results both on Explorer and Netscape

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
coopaAuthor Commented:
Thanks damianosky,

That still doesn't explain why it works with TD but not with TH....  

The TH code is almost identical as the TD code but is being completely ignored.
0
 
coopaAuthor Commented:
I have updated the example (with tzarad's comments):
www.coopa.demon.co.uk/ee/test.htm 
www.coopa.demon.co.uk/ee/test.css 
0
 
damianoskyCommented:
Probably there is no valid reason...

Simply Netscape does not allow you to redefine th: th is the header of table's cells; yours is a question probably only netscape's men can answer...

I've seen your code... Formerly, it's correct.

As i've told you, this is only one of the mysteries of Netscape behaviour...

Also font dimension is not the real dimension: Netscape use the most similar dimension between the 7 standard levels (according also to the configuration in your preferences).

Moreover, why you need to use TH? Yes, of course, this is HTML-compliant, but there is no obligation to not use simply TD with a class definition as i've suggested you...

Just a roundtip... i know... :-|

0
 
coopaAuthor Commented:
> Moreover, why you need to use TH?
Because after i've finished designing 'the perfect' style sheet, a bunch of complete computer illerterates are going to use it to produce live web pages...  

Having the ability to specify cells in a table as being 'header cells' may help these imbeciles... hehehe.

8o)
0
 
damianoskyCommented:
Couriosely, i've donwloaded your code on my PC and now on my Communicator (Italian version 4.5) your code does its work with TH, while with TD the character dimension fails... (while on the web the behaviour is the yours...)!!!

mmmm....mystery

This is an interesting and courious problem...


0
 
coopaAuthor Commented:
I'll leave the question open just in case anyone else has anything to offer.
Thanks anyways.
0
 
tarassovCommented:
Here is the answer for your question. I have tested your css file and found out that problem was in this string:
background-color = #004080;
Netscape doesn't like "=" symbol as I see ;)

So, the th style should look like this:

th{
 Color: white;
 fontFamily: arial, helvetica, swiss, sans-serif;
 fontSize: 7pt;
 backgroundColor: "#004080";
 fontWeight: bold;
}

Best wishes,

  Andrey
0
 
coopaAuthor Commented:
tarassov:
Perfect answer.... Although you only solved half.

tzarad: I owe you some points... I will post as a separate question.


0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now