Solved

Documents created using agent do not enforce readers field

Posted on 2000-04-03
4
288 Views
Last Modified: 2013-12-18
Hi,

I have an agent which creates documents and populates readers and authors fields. Once the agent is done running, anyone with reader access to the database can access all of the documents, even if they are not in the readers field! Doing a ToolsRefreshAllDocuments fixes the problem, but I don't like this solution. I don't want anyone who is not listed as a reader to be able to view these documents at any time, instead of the current solution where they can see it between the time that document was created by the agent and the time the refresh is run.

Why is this like this and how can I fix it?

(Sorry I don't have more points to spare)

Zaphod.
0
Comment
Question by:Z_Beeblebrox
  • 3
4 Comments
 
LVL 1

Accepted Solution

by:
sk5t earned 30 total points
ID: 2681736
If you are doing this with script, you'll need to set the .IsAuthors and .IsReaders properties on those fields.  Until the document is actually computed with the form (which [ToolsRefreshAllDocuments] does), whatever you have assigned to the fields are "just plain values" to Notes.  Use NotesDocument.ComputeWithForm in LotusScript.

If the agent is purely formula language, and it does not run on the frontend, then it gets kind of messy.  (By which I mean, you'll probably have to write the document's UNID to an environment variable, then do @Command([ToolsRunMacro]) for a LotusScript agent that gets the doc by that UNID and runs ComputeWithForm on it.)

Steve
0
 
LVL 7

Author Comment

by:Z_Beeblebrox
ID: 2681783
Thanks for the quick response. calling doc.ComputeWithForm (True, True) just before saving the document did the trick.

Zaphod.
0
 
LVL 7

Author Comment

by:Z_Beeblebrox
ID: 2681874
Whoah, I think I was a bit too quick to dish out the points. That solution worked a little too well. I had a field which was of type authors which had as a default value the creator of the document, namely me. However I can no longer see the documents. I know they are there, but there is no way that I can get to them.

Zaphod.
0
 
LVL 7

Author Comment

by:Z_Beeblebrox
ID: 2681905
Yikes, another issue. I have a role called [Readers] which allows people to read all documents in the database. However the agent does not respect this.

I can get around the previous issue by manually setting the field to be the current user, but this role thing is a bit of a problem.

Zaphod.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
IBM Notes offer Encryption feature using which the user can secure its NSF emails or entire database easily. In this section we will discuss about the process to Encrypt Incoming and Outgoing Mails in depth.
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now