• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 896
  • Last Modified:

Running Microsoft SourceSafe from the command line

I'm trying to get the latest verision of a project, using the command line parameters. But SS keep asking me for username and password, but I cant login.

ss Get $/myproj -R

My user/password is ok when running the GUI.
The project exists

Any clues?

0
ChristerH
Asked:
ChristerH
  • 5
  • 3
  • 2
  • +2
1 Solution
 
jkrCommented:
Have your tried an account name like

DOMAIN\user

?
0
 
chensuCommented:
You can set the SSUSER environment variable to your user name to avoid the logon prompt each time you enter a command from the command prompt. For example,

set ssuser=ChristerH
0
 
nv3prasadCommented:
When starting the Visual SouceSafe Explorer (ssexp.exe), the -y command line option could be used to specify the Vss userid.

Make a short cut to ssexp.exe and add the following command line parameters.

For example, "C:\Program Files\Microsoft Visual studio\VSS\win32\SSEXP.EXE" "-yChristerH"

In addition, the -p and -s command line options could be used to specify the srcafe.ini (database) and project name respectively.

For example,
"C:\Program Files\Microsoft Visual Studio\VSS\win32\SSEXP.EXE" "-yChristerH " "-p$/myprojr" "-s\\DOMAIN\SOURCESAFEDATABASE"
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
ChristerHAuthor Commented:
I have to test these tips, I'll be back ...
0
 
ChristerHAuthor Commented:
Hi!

Domain does not work ...

>ss Get
Username: MyDomainName\Christer
Password: ******
Bad username syntax: "MyDomainName\Christer"

I don't want to run ssexp, only the command line ss program.

I also tried with

ss Get -p$/MyProj -R -s\\MyServer\MyShare\srcsafe.ini

More clues?

/Christer
0
 
chensuCommented:
Have you tried my suggestion?
0
 
ChristerHAuthor Commented:
yes, unfortunately it did not work ...
0
 
chensuCommented:
Make sur that your SS user name and password are the same as your domain user name and password.
0
 
ChristerHAuthor Commented:
They are the same .... more ideas?
0
 
ChristerHAuthor Commented:
It works if I write

\\MyServer\MyShare\win32\ss.exe Get $/Installation -R

why?
0
 
opichalsCommented:
Hi! I have the same problems some time recently. Everything was solved by setting the ssdir environment variable to the right SS database path.
like

ssdir=//server/sourcesafe

regards

Stan
0
 
opichalsCommented:
Sorry the previous comment should be assigned as answer to your problem.

Hi! I have the same problems recently. Everything was solved by setting the ssdir environment variable to the right SS database path. Like:

ssdir=//server/sourcesafe

regards

Stan
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

  • 5
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now