Solved

qmail relaying

Posted on 2000-04-04
4
349 Views
Last Modified: 2010-03-18
I just installed qmail and am having some trouble with relaying (at least that what i think)  when i delete my /var/qmail/control/rhcphost file everything works fine. but when its there i cant send a message to anybody whos domain is not in that file.  I thought that relaying was just to prevent people from sending messages through your smtp from places that were not specified.  I didnt think it mattered where the messages were addressed.

what i want to happen is relaying only to be allowed from localhost and my internal network. But i want to be able to send mail to anyone with out adding there domain to the rhcpfile

Any help would be great
lugnut1221
0
Comment
Question by:lugnut1221
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 

Expert Comment

by:cReverd
ID: 2720495
Hi,

You just have to set up both /var/qmail/control/rcpthosts and /var/qmail/control/virtualdomains with a fully qualified domain names list.

Then using the TCPserver you have to setup the SMTP database access with your authorized IP address :

192.168.0.*:allow,RELAYCLIENT=""
10.0.0.*.*:allow,RELAYCLIENT=""
:allow

Dan Bernstein's ucspi-tcp package is available at http://cr.yp.to/ucspi-tcp.html

And finally rebuild the SMTP database :

tcprules tcp.smtp.cdb tcp.smtp.temp < tcp.smtp

It should works as you expect !

Christophe Reverd
Xon-Xoff, Paris.
0
 

Author Comment

by:lugnut1221
ID: 2721598
Thats what i did do but i cant possible put all ips that i want to recieve from or send to...i thought the relaying only limited where you could send the mail from.
0
 

Expert Comment

by:cReverd
ID: 2721778
Relay option is for YOUR local IP range not worlwide one !

Try this please.
0
 

Accepted Solution

by:
dkieta earned 100 total points
ID: 2759224
You only want to allow relaying for your local net, not anyone else.

If you set up the tcpserver as cReverd explains, and define your entire internal network in the SMTP database. That will allow for relaying for local machines and deny relaying to anyone that is not defined in that database. (The internal machines will be able to send mail to ANYONE, external machines will only be able to send mail to YOU!)

Just put your domain in the rcpthosts file, and all should work for you.
0

Featured Post

Congratulations! You’re Certified – Now What?

Starting a new career can be overwhelming. Becoming certified in your field of expertise is a great start, but where do you go from here?  Here are some tips to help you on your career journey.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question