Solved

Agfa 1212P Scanner Won't Work

Posted on 2000-04-04
19
587 Views
Last Modified: 2013-12-28
I have installed an Agfa SnapScan 1212P on A Compaq Deskpro En 400Mhz PC with 64Mb RAM along with all the latest software, however whenever I try to scan anything I receive the message "Please connect or switch on your scanner". I am also having similar problems with an Aries Scanner and a Deskpro EP (PII 350 196Mb RAM); I don't know whether this could be related. Both machines exhibit this problem with nothing running but Windows 98 and Sophos Sweep (Anti Virus Software) running. I have tried the obvious, checked cables etc but this doesn't seem to help. Any Ideas?
0
Comment
Question by:andres99
  • 3
  • 2
  • 2
  • +8
19 Comments
 
LVL 6

Expert Comment

by:Zoplax
Comment Utility
I've had the exact same problem with the Agfa 1212P.

Despite some e-mail support from Agfa, their suggestions didn't solve my problem, so I'm basically unable to use their SnapScan software.

Instead, I installed Agfa Fotolook, and it appears to scan with no problems.  If Fotolook provides adequate functionality for what you want to do, I'd say install it and use it.

Otherwise, try opening an incident with Agfa support.
0
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
I would try disabling the antivirus.
Also
Download the Startup COP a free pcmag utility from
                       http://www.zdnet.com/pcmag/pctech/content/18/08/ut1808.001.html

 Run it and it will show you everything that is listed in all the possible startup
places, and allow you to disable things one at a time until the problem is eliminated.

One more thing, make sure that you have tried all the possible parallel port definitions, PS/2 , bidirectional. EPP, and ECP. They should be changed in the BIOS setup.
If not, try another software package.

I hope this helps.
0
 
LVL 7

Expert Comment

by:sorgie
Comment Utility
OK I'll ask the dumb question (I had a HP that worked this way) Do you have power to your scanner on bootup?
If my HP was off at bootup WIndows would not see it working
0
 
LVL 21

Expert Comment

by:briancassin
Comment Utility
adres how is the scanner attached USB, Parallel or SCSI ?

have your tried installing by hitting ctrl,alt,delete and end tasking everything except for explorer and systray then install the scanner ?
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
Comment Utility
andres99,
Check first, switch on the scanner till it is ready to use before the switch on your computer.
Secondly, check with the termination.
Thirdly, if it is a SCSI scanner, inspect the SCSI card. If it is a 8 bit or 16bit SCSI card, replace with a 32bit SCSI.
In addition, go to check with the C:\windows\Twain_32, if there is driver folder for your scanner. Before starting to scan, select the twain source using the Twain_32, then start to scan by Twain_32.

If you have queries, please specify.  pslh
0
 

Author Comment

by:andres99
Comment Utility
The scanner is connected via a parallel port,

There is no on/off button on the scanner, it is only powered on/off from the mains.

I have checked and there is definatly no option to change the port to EPP, only Flexible, Standard or Output only.

I'm afraid Fotolook brings up the same problem as the SnapScan software that came with the scanner.

Cheers Andre
0
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
Have you tried with both flexible and standard BIOS settings ?
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
Comment Utility
andres99,
The SnapScan 1212p, with Agfa's Enhanced Parallel Port, is a true plug-and-play scanner. There are no internal controller cards to install. The user attaches the parallel cable, plugs it in and loads the software—the SnapScan is ready to use in just seconds. For computers with only one parallel (printer) port, the SnapScan 1212p has a second parallel port, so the user can daisy-chain the connection from computer to scanner, then scanner to the printer. The Enhanced Parallel Port (EPP) interface ensures reliable connectivity.

Therefore, Go to the CMOS/BIOS by pressing <DEL> or <F2> or <F10> just after RAM testing during bootup. Go to the page with peripherals and set the parrallel port as EPP/ECP. Save and exit. Checking that your connection is right. Then uninstall all the existing software of SnapScan and restart computer. Unplug the scanner from the computer at power off. Restart computer and install the FotoLook which is more win98 compatible for Twain_32 source in 32bit.
Do not use Fotosnap which is 16bit using Twain_16 source.

After finished, shutdown and connect your scanner. Restart computer and see if it is well installed in the device manager. Prior from that checking with the manual, the scanner may need initialization at the first time it is unpacked. Moreover, inspect if you have not yet unlocked the scanner. If that is the case,  normally at the back near the bottom or close to the lens there is a locker which prevents vibration during shipment, unlock it.
Afterwards, open Fotolook, select Twain_32 source first and OK. Then try to start scanning.
 
<<I have checked and there is definatly no option to change the port to EPP, only Flexible, Standard or Output only. >> Normally, the CMOS/BIOS will not use the words Flexible, Standard or Output only for setting the configuration of parrallel port. You must have to check it again. Moreover, if the parrallel port of your motherboard does not support EPP/ECP, unfortunately you cannot use this kind of method to connect a EPP scanner. If it were the case, you've to connect such a scanner with an EPP support computer.

pslh
0
 
LVL 5

Expert Comment

by:buddhole
Comment Utility
Download scanwise v1.2, throw your agfa inf's away from \windows\inf and \windows\inf\other. Uninstall your version of scanwise, restart your computer and install v1.2, before rebooting, goto device manager and click refresh twice.
This should solve all your problems. If you want to change your Parallel port on your compaq, download softpaq 2158 and add the setport porgram to your autoexec.bat as following:
setport 3
don't forget 3, it stands for EPP

0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:andres99
Comment Utility
I have already installed SnapSCan v1.2 and have also  setup softpaq 2158, it works fine when booting, you can see by pressing F8 on boot that the port has been changed, however it has been changed back to bi-directional by the time you reach Windows
0
 
LVL 5

Expert Comment

by:SemperPhi
Comment Utility
Compaq's have a unique parallel port.

Do you have the space to install a second parallel port?

I use the SIIG ECP ISA parallel set to 0278 NO IRQ (windows doesnt need it).

0
 
LVL 5

Expert Comment

by:buddhole
Comment Utility
Install snapscan the way I told you....
Else do a clean reinstall of windows and the reinstall snapscan 1.2 (are you sure you're using 1.2, on the 1.0 cd it says 1.2)
0
 
LVL 5

Expert Comment

by:compmania
Comment Utility
Try this:

Start the computer and hit F8 several times until the new menu comes up,
choose safe mode.
After it loads up you want to go to device manager
(right click on my computer, choose properites, device manager tab at the top)
remove all scanner devices,
any "ghost" devices (ones listed more than one time and are not listed in normal mode)
and any that have yellow !'s, ?'s or red X's.
Restart
0
 
LVL 2

Expert Comment

by:manikantan
Comment Utility
When U Install the Scanner Driver...
or Reboot Ur System
Does Ur Scanner Get Recoganised....
If Recoganised.. there might be Some problem in the power to the Scanner or the Scanner itself....

There can Also Be Problem In the Port To which u are Plugging ur scanner...
Please Check The Port ....
It May Give u the Results
Regards
Manikantan
0
 
LVL 4

Accepted Solution

by:
jmfairchild earned 500 total points
Comment Utility
You are getting the error message: "Please connect or switch on your scanner" because the software cannot "see" your scanner through the parallel port.

The Compaq site shows that your model DOES have SPP as well as EPP & ECP capabilities. ECP (Enhanced Capability Port) and EPP (Enhanced Parallel Port) are bi-directional. Without bi-directional communication (to/from devices on your parallel port), your current configuration will never work (as pslh referenced). You will need to access the CMOS setup and goto the menu that references "peripherals":

1) Ensure that the parallel port is ENABLEd.

2) Ensure that the parallel port is set to either EPP, or ECP. If neither setting is available (as you reference above), use "flexible".

Also:

3) Ensure that you have a "bi-directional" cable between your parallel port and your scanner. Older parallel cables were only "one-way" (out).

4) Ensure that the parallel cable is plugged into the correct parallel port on the Agfa. It has two ports, one for "in", which is the one you want, and one for "out" (to daisy chain a printer).

5) The Agfa miniport driver ONLY supports memory addresses 0x278 and 0x378. Ensure that the parallel port is configured for one or the other memory address.

6) If ALL ELSE FAILS, use Agfa's "cure-all" solution (ensure to follow it STEP-BY-STEP):

  a) Goto http://support.agfa.com/docPubCISsearch/

  b) Select:
"Product name:" SnapScan 1212P,
"Document topic:" - All Topics -
"Keyword/Phrase:" unexpected error 1212P
"Files to Return:" 1

I would have posted the direct link, but the way their site is setup, it would be a page long url. This will be easier.

Just looking to help close a way overdue question.

- Jim
0
 
LVL 4

Expert Comment

by:jmfairchild
Comment Utility
One change to the above: If you get down to using Agfa's "cure-all", do the search on keywords: "unexpected error" ONLY (without the quotes obviously). I just found that 1212p is not a keyword to that message (go figure!)

- Jim
0
 
LVL 5

Expert Comment

by:compmania
Comment Utility
Any luck andres99?
0
 
LVL 4

Expert Comment

by:jmfairchild
Comment Utility
Thank you, sir. May I ask for future "searchers" what solved the problem?

- Jim
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

A Bare Metal Image backup allows for the restore of an entire system to a similar or dissimilar hardware. They are highly useful for migrations and disaster recovery. Bare Metal Image backups support Full and Incremental backups. Differential backup…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now