Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Forwarding Problem with Linux server

Posted on 2000-04-04
9
Medium Priority
?
255 Views
Last Modified: 2010-03-18
Hi,

I have setup a 486 with linux to act as my home network server.  Everything looks good, but I can not get out to the internet through the server.  I think I have narrowed the problem down to the server not having the gateways setup correctly.  Specifically, netstat returns this:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.0.25    0.0.0.0         255.255.255.255 UH        0 0          0 eth0
24.11.169.17    0.0.0.0         255.255.255.255 UH        0 0          0 eth1
24.11.169.0     24.11.169.17    255.255.255.128 UG        0 0          0 eth1
24.11.169.0     0.0.0.0         255.255.255.128 U         0 0          0 eth1
192.168.0.0     192.168.0.25    255.255.255.0   UG        0 0          0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
0.0.0.0         24.11.169.17    0.0.0.0         UG        0 0          0 eth1


With ifconfig looking like this:

eth0      Link encap:Ethernet  HWaddr 00:60:8C:F6:6B:91  
          inet addr:192.168.0.25  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9354 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13837 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:5 Base address:0x310

eth1      Link encap:Ethernet  HWaddr 00:C0:F0:36:28:9C  
          inet addr:24.11.169.17  Bcast:24.11.169.127  Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6658 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:3 Base address:0x240

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0



I think the problem lays with my 192.168.0.25 ip address showing up as a gateway.  I think 24.11.169.17 should be he gateway -- or at least the two should talk (thier on the same machine).  How do I trouble shoot this?  Let me know what Info you need and I will quickly supply it.  I would love to get this working quickly.  Thanks

Nasa
0
Comment
Question by:nasa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 7

Expert Comment

by:lewisg
ID: 2685989
I think your routing table has too much stuff and is missing a route to your ISP's gateway. Here is a copy of mine (modified to protect the guilty...)

172.20.1.1 is my private ip address
212.230.220.4 is my public ip address
255.255.255.192 is the netmask for above
212.230.220.1 is my ISP's gateway

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.20.1.1      *               255.255.255.255 UH    0      0        0 eth0
212.230.220.4   *               255.255.255.255 UH    0      0        0 eth1
212.230.220.0   *               255.255.255.192 U     0      0        0 eth1
172.20.1.0      *               255.255.255.0   U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         212.230.220.1   0.0.0.0         UG    0      0        0 eth1

All the stuff up to the last line was generated by default. The last line is generated by adding this to /etc/rc.d/rc.local

route add default gw 212.230.220.1 eth1

You can use route del to remove bad entrys in the routing table.

After you get this set up you will need to get ipchains running to handle Network Address Translation...
0
 
LVL 1

Author Comment

by:nasa
ID: 2686046
Ok,

My bad ... I had already had it fixed, just didn't notice it.  The gateway settings on the machine I was trying this from wasn't set correctly.

Nasa
0
 
LVL 1

Author Comment

by:nasa
ID: 2686150
This question has a deletion request Pending
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 7

Expert Comment

by:lewisg
ID: 2686224
This question no longer is pending deletion
0
 
LVL 7

Expert Comment

by:lewisg
ID: 2686225
I am confused!

You had a question about a problem. I had a comment (which could have been an answer) that had a direct bearing on your problem.

Is the problem solved?

If so and my comment helped you should accept my comment as the answer, not delete the question...
0
 
LVL 1

Author Comment

by:nasa
ID: 2686256
I am sorry,

I had corrected the problem before I checked for any replies.  Thus I never looked at your comments.  However, I am still running into a slight problem you may be able to help me with.  I can get to the web via linux, but not windows.  I have configured both sides of my computer the same.  The only thing I noted is that Windows doesn't see my linux server.  Could this be a problem?  I did not expect Win98 to see the Linux server as it is pure linux -- does it have to?  Do I need samba?

Nasa
0
 
LVL 10

Expert Comment

by:rbr
ID: 2686490
You posted another question with the same problem. There I gave you the answer. You should give the points to lewisg for this answer since he/she gave you the correct answer even you found it too.
0
 
LVL 7

Accepted Solution

by:
lewisg earned 800 total points
ID: 2687081
You don't need Samba to use your linux box as a internet gateway for your windows machines. You do need to set up TCP/IP on the windows machines using the linux machine's IP as their gateway. In addition you will need the linux machine to do NAT (ipchains&ipmasquerade).
0
 
LVL 1

Author Comment

by:nasa
ID: 2688637
Your correct -- samba is not necessay and I have everything working now.  Thanks

Nasa
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question