Solved

startx fails

Posted on 2000-04-04
9
730 Views
Last Modified: 2010-04-20
I have RH 6.1 installed.  There are six login id's.  On four i can startx and go along fine.  On two id's when i try to startx i get a message 'authentication failed  cannot start x server ...perhaps you do not have console ownership--cannot connect errno=111---giving up---xixit connection refused'
when i go back into the home directory there is this .enlightenment and .genome directories which does not happen in the other login id's.  How do i get it so i can startx.
0
Comment
Question by:xoxomos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 4

Expert Comment

by:Robson
ID: 2687004
On standard RH 6.1 installation only one user is allowed to have console ownership. Don't you log two users at once? Anyway, your problem is conected with PAM module. You can find brief desciption of this mechanism in RH documentation. 'man pam' displays more detailed information.
0
 

Expert Comment

by:cheneque
ID: 2687005
It seems like a troble with the user rights, look in the /dev subdirectory and verify the "console" device rights with the "ls -l" command and give de correct rigths wit the "chmod 766 console" command.

Other solution it´s add the user that dosen´t work to the group of the users that works fine.

See ya in advance
0
 

Author Comment

by:xoxomos
ID: 2690320
cheneque
i looked at another machine under /etc/console and it had the same settings as mine.  console showed crw------- root  root as does mine
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Expert Comment

by:cheneque
ID: 2690515
try with another console like this

startx -- :1   /* the tty7 or F8  */
startx -- :2   /* the tty8 or F9  */
startx -- :3   /* the tty9 or F10 */


other thing that you can do is go to the /etc/X11 and backup the "XF86Config" file and remove it.
After that Generate a new one as root with the "setup" comand and generate a new configuration (its necesary don´t do this with the X server up.

Question:

Are you entering in the 5 level (xwindows) or the 3 level (text) of the operating system when it start's
0
 

Accepted Solution

by:
cheneque earned 75 total points
ID: 2690516
try with another console like this

startx -- :1   /* the tty7 or F8  */
startx -- :2   /* the tty8 or F9  */
startx -- :3   /* the tty9 or F10 */


other thing that you can do is go to the /etc/X11 and backup the "XF86Config" file and remove it.
After that Generate a new one as root with the "setup" comand and generate a new configuration (its necesary don´t do this with the X server up.

Question:

Are you entering in the 5 level (xwindows) or the 3 level (text) of the operating system when it start's
0
 

Author Comment

by:xoxomos
ID: 2690929
Adjusted points from 50 to 75
0
 

Author Comment

by:xoxomos
ID: 2690930
O.K. O.K.  i don't know what is happening but i tried the --:3 business and it works.  Let me increase this a little bit and ask what is the --3: and where do you look to find out about it?
0
 

Author Comment

by:xoxomos
ID: 2690936
Thanks!!
0
 

Expert Comment

by:cheneque
ID: 2693720
I found the configuration in the xinit man page and debuging by hand the startx script

Thanks for the points and good look in this way of Linux

By default the :0 console is in the F7 or tty6 but the -- :# option lets you take the terminals after F7

0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question