Solved

CF Grid error with oracle

Posted on 2000-05-15
4
226 Views
Last Modified: 2013-12-24
I used the example code that came w/CF Studio 4.5 using the access database w/cfsnippet datasource.  Yet when i replace the query & datasource with an oracle one (were using the oracle 7.3 native driver) along with the changes to the grid columns. It loads the applet up just fine but when u try to update it i come back with the error:

The table 'auction_fut' contained no columns in the grid 'cforacle'.


This error may have been caused by not specifying the table name in the format which the ODBC data source expects (e.g. SQL Server table names must be qualified with the database name and table owner, as in 'customers.dbo.orders').

Not sure what this means? Any suggestions?
0
Comment
Question by:dolomite
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 2

Expert Comment

by:dlewis9
ID: 2814103
Can you post your code?  I think I found the example you are referencing, but it will help to see your modifications...

The error message suggests that perhaps you need to preface your table name with the table owner on the CFGRIDUPDATE and possibly in the CFQUERY...sounds like they're not matching somewhere..it's pretty picky.  If you can post debug info, that may help too because you can see the Form variables that the CFGRID creates.
0
 
LVL 5

Expert Comment

by:nathans
ID: 2821308
I have a feeling you may have to manually update instead of using the CFGRIDUPDATE

Nathans
ColdFusion Tips Plus
www.nsnd.com
0
 
LVL 9

Accepted Solution

by:
Dain_Anderson earned 50 total points
ID: 2828417
First off, make sure you have Oracle version 7.3.4.0.0 or better; otherwise, it may not work. Also, make sure your default database name in your datasource is set correctly -- if not, you are connecting to the wrong one.
You can override this by using the DBNAME attribute. Since this is Oracle, your TABLENAME attribute's value must be in uppercase letters. It might be wise to use the TABLEQUALIFIER attribute to specify which database holds the table specified in TABLENAME.
   
It sounds like you need to uppercase the table name and add the TABLEOWNER attribute -- this will add the owner before the database objects.

In Oracle, it should look like this:

<CFGRIDUPDATE
    GRID="myGrid"
    DATASOURCE="myDSN"
    DBTYPE="Oracle73"
    DBSERVER="myDBserverName"
    DBNAME="dbName"
    TABLENAME="TABLE_NAME"
    TABLEOWNER="owner"
    TABLEQUALIFIER="databaseNameInOracle">

Hope that helps
0
 

Author Comment

by:dolomite
ID: 2834202
Thanks, that did the trick.  The code works like a champ now.
0

Featured Post

Turn Insights into Action

Communication across every corner of your business is essential to increase the velocity of your application delivery and support pipeline. Automate, standardize, and contextualize your communication processes with xMatters.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is a guide to setting up a new WHM/cPanel Server to be used for web hosting accounts. It is intended for web hosting company administrators and dedicated server owners. For under $99 per month (considering normal rate of Big Data Cetnters like …
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question