Solved

mount

Posted on 2000-04-06
5
393 Views
Last Modified: 2010-04-20
How can I define the 'mount' ?
Still got a question:
   why that sometimes I can't mount my cdrom so that I can access to my cdrom ?
0
Comment
Question by:ahchong
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 17

Expert Comment

by:psimation
ID: 2690527
mount --help
man mount
the usage is typically:
mount /dev/hdc -t iso9660 /mnt/cdrom

if your cdrom is secondary master.
Primary master = hda, primary slave = hdb
Secondary master = hdc, Secondary slave = hdd
Remember, when mounting hard drives, you must also add the number of the partition, eg. /dev/hda5 -t vfat /mnt/winfiles

0
 
LVL 3

Expert Comment

by:DVB
ID: 2691577
Look up in your /etc/fstab file to make sure that non root users have permission to mount removable devices like CDs and floppy disks. (for the ocassional problem)
0
 
LVL 3

Expert Comment

by:jyu_88
ID: 2691687
/dev/cdrom              /mnt/cdrom              iso9660 noauto,user,ro  0 0
in your /etc/fstab. The user option is to allow non-root user to mount your CD at /mnt/cdrom.
If you do things as root, you have almost all the permissions. If you act as ordinary user, you have a lot less rights to access
system resources, be that CDROM, modem, file systems, etc.
0
 
LVL 3

Expert Comment

by:jyu_88
ID: 2691715
/dev/cdrom              /mnt/cdrom              iso9660 noauto,user,ro  0 0
in your /etc/fstab. The user option is to allow non-root user to mount your CD at /mnt/cdrom.
If you do things as root, you have almost all the permissions. If you act as ordinary user, you have a lot less rights to access
system resources, be that CDROM, modem, file systems, etc.
0
 

Accepted Solution

by:
AbbasAhmed earned 15 total points
ID: 2694209
Take a look at your /proc/filesystems file using
cat /proc/filesystems
to check whether your kernel supports the iso9660 filesystem which comes on CD-ROMs. If so, try using
mount /dev/cdrom /mnt/cdrom
here "-t iso9660" option is optional.

But if you want to specify your CD-ROM drive as:

/dev/hdb      Primary IDE Slave or
/dev/hdc      Secondary IDE Master or
/dev/hdd      Seconday IDE Slave instead of /dev/cdrom you should know  that your CD-ROM drive is which one of these.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
open source backup solution 1 45
What is linux 4.8.22? Is it the same as ubuntu 16.10 ?? 2 75
Centos 7 DNS server not replying to clients 3 57
SMTP log file for IMSVA 5 35
Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question