Samba Questions

I am fairly new to using Linux and have endeavored to try and get my Linux box visble on my lan. I have edited the smb.conf file multiple times with no success. There seems to be no PDS on the network, and I'm am not entirely sure how it is set up. Any suggestions as to how I can set up Samba so that others can see my files.

dhirst
dhirst040600Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
pheurConnect With a Mentor Commented:
First, make ure that windoze stations have TCPIP installed, and they are configured to accept NetBios over TCPIP.
Second, make sure windozes and Linux are on the same IP subnet.
Third, try the following config file (working version here - works for NT workstations). The server announces itself as NT Workstations (to real NT Workstations) and prefers to be domain master.

# Global parameters
        workgroup = WORKGROUP
        netbios name = SERVERNAME
        server string = Samba Server
        security = SHARE
        encrypt passwords = Yes
        update encrypted = no
        log file = /var/log/samba/log.%m
        smb passwd file = /etc/smbpasswd
        nt smb support = No
        nt pipe support = No
        announce version = 4.1
        announce as = NT Workstation
        max open files = 100
        socket options = TCP_NODELAY
        load printers = No
        os level = 64
        preferred master = Yes
        domain master = Yes
        create mask = 0644
[homes]
        comment = Home Directories
        read only = No
[printers]
        comment = All Printers
        path = /var/spool/samba
        print ok = Yes
        browseable = No
[ftp]
        comment = FTP Archive
        path = /home/ftp/pub
        guest only = Yes
        guest ok = Yes
0
 
lewisgCommented:
1. Be sure the machines can ping each other.

2. Replace you smb.conf file with this as a test. Do a samba stop and samba start after replacing the file.

[global]
workgroup = WORKGROUP
server string = test
encrypt passwords = yes
smb passwd file = /etc/smbpasswd

[homes]
browseable = no
writable = yes

3. Be sure your windows machine is in the WORKGROUP workgroup.

At this point you should be able to see the linux machine in network neighborhood.

To be able to access the share in homes you need to set up a linux and smbuser with the same name and password as you use when logging into windows.

Always run testparm after you edit your smb.conf file
0
 
lewisgCommented:
pheur - Is there any substantial difference between your proposed answer and my comment?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.