Proper video Settings for the Intel 810 video card

I installed Red Hat Linux on my machine and couldn't get Xwindow to work. So I installed some new RPMs and edited the XF86Config file. Now I can run Xwindow but the screen is small and doesn't show the whole picture. I can scroll to see the rest but this is very annoying when I am using higher resolutions. I am assuming that this has something to do with the SVGA driver but I have no idea how to edit it. Please help
KogaruAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
Did you follow all the steps in the Intel doc's? If so you should be okay as far as the setup is concerned. I'm guessing that your problem is that you want a higher res screen without needing to scroll and you can accomplish that by editing the XF86Config file and removing unwanted modes (the doc's say that, but it might not have registered). For example, if I only want a 16bpp mode at 1024x768 I'd delete the "Subsections" for "Depth 8" and "Depth 24" and remove all modes but 1024x768 from the remaining "Subsection, like so:

Subsection "Display"
   Depth      16
   Modes      "1024x768"
   ViewPort    0 0
EndSubsection

If you need to, you can fine tune the display with xvidtune. Since it doesn't modify the XF86Config file, as soon as you start it (from a shell window) click the "Show" button and it'll print the current mode line on the the shell window. Fiddle with the settings until you've got the display looking like you want and click the "Show" button again. Use the first mode line to find exactly that line in XF86Config and change it to be what the second like is. From then on X will start with those settings.
0
 
jlevieCommented:
What did you use to configure the X server? On RH, Xconfigurator is probably the best choice as it will test the config and you know that it is or isn't right on-the-spot. When you run Xconfigurator you can pick a single resoloution/depth from it's table and that will automatically eliminate the scrolling. I normally pick the highest (or one of the highest) resolution and the most colors that the card and monitor support.
0
 
KogaruAuthor Commented:
I used the Xconfigurator upon install and that it did not work. The higher the resoloution is the more I have to scroll. Here is the exact process I went through to get it to work

http://support.intel.com/support/graphics/intel810/release_notes_1.htm

and here are the rpms I used

http://support.intel.com/support/graphics/intel810/linuxsoftware.htm


Thanks for trying jlevie
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
KogaruAuthor Commented:
Perfect thanks for the help! It is strange yesterday I removed all of the modes except for "640x480" (or whatever the lowest mode is) and I still had to scroll. But today when I tried it again with a higher mode it worked perfectly. Thanks for your help.
0
 
KogaruAuthor Commented:
Perfect thanks for the help! It is strange yesterday I removed all of the modes except for "640x480" (or whatever the lowest mode is) and I still had to scroll. But today when I tried it again with a higher mode it worked perfectly. Thanks for your help.
0
 
jlevieCommented:
You are most welcome...
0
All Courses

From novice to tech pro — start learning today.