• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 217
  • Last Modified:

mount permissions

I use mandrake 7.0 and would like to share a vfat drive with samba for reading, and writing.  I've got samba setup right but the clients can't write since the vfat drive is not mounted with write permisions for anyone but root.  I tried to chmod it but that failed.  What is the proper way to mount a drive read / write for all.  
Currently only root can write, even non-root user is logged in to the console (not using samba)
1 Solution
You can edit your /etc/fstab and add the option umask=000 for that partition -- but beware: that means anyone on the network can write to the partition. Check the man page for mount (8), you can also set owner and group using the uid and gid options.
Maybe umasking from the users profile file will help prevent that problem (Allowing everybody to write to the disk)?
Just my 2<currency units>
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now