• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 194
  • Last Modified:

Problems with saving web files to site

I have had an ongoing problem when it comes to saving various files to a web site, but now I need to find a solution : )  In the past I have run a database and asp pages off of my site,  the problem was whenever someone came to the site and went to the asp pages, the database was 'locked' and you could not write or save to it. It continued to be locked for a few minutes after someone accessed the page. Now the same thing has happened with plain o' htm files. If someone, anyone in the world, has the file open, then the person that needs to update it or save to it can not write to it. The program that they are using to write to the html page comes back saying that a permission error has occurred, although permissions are set up correctly. I am suspisious of some sort of 'caching feature' in IIS on the web site side that may be causeing this, if anybody know ifs IIS automatically does this.

I am running IIS on NT 4, users contect to the web site through a shared folder through a LAN. Proxy server is also running on the same machine and it is used for access to a T1 by about 250 computers.

Thanx!
0
Occhio
Asked:
Occhio
  • 4
  • 4
  • 2
  • +2
1 Solution
 
mgfranzCommented:
I doubt if it is a caching issue more than a dB access issue, are you closing and setting your connections and recordsets to Nothing after retrieval of data?

Plus if you were using Sessions you could reset the dB upon a button click or page close.
0
 
OcchioAuthor Commented:
It is not just the db, it's anything - once a user accesses anything on the website, it is 'locked' for any other type of access (except through the website) for a few minutes. During the day when our site gets a hit every minute or so, no editing can be done to any of the files on the site.
0
 
mgfranzCommented:
???  
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
hkmdjCommented:
Please Read This:

http://support.microsoft.com/support/kb/articles/Q191/7/42.ASP

It includes a registry change for Disabling the caching of file handles.

I made the changes and it works great.

0
 
mgfranzCommented:
hkmdj,

Read the question again... while your fix is nice, it is not a fix for the original question.  What Occhio is having a problem with is when client either views or opens a page for viewing, it locks the page for a few minutes.  

Unless we are reading the question wrong... :-|
0
 
OcchioAuthor Commented:
Actually, it sounds like hkmdj's suggestion it about what I am looking for, I am going to give it a try today and see if that works - I will post results here.

I'll try to describe the problem again in other words.

Mr. Internet User comes along to my website and is looking at default.htm. That's all fine, Mr. Internet User gets the page and leaves. Then when I go to open edit or even look at default.htm (through a network share) I am denied access (among other similiar problems), even as administrator (and yes admin has correct permissions). If I want to veiw the page through through Http, it's fine. It's as if the proxy server has locked the file while it's cached for a few minues so it doesn't have to 'reload' it every time someone comes across the page. Everything works fine after a set amount of time as past.
I hope that helps to clearify the problem.
0
 
hkmdjCommented:
I got to tell you, I made the change yesterday and it has changed my life.  I use a variety of third party editors, depending on what I need... such as global search and replace, tag coloring, whatever.  VI, HomeSite, 1stPage, HTML-Kit, I use them.  The thing that drives me most crazy during development is not being able to save out a file.  I close my browser window, wait 1 to 5 minutes, and then save.  Or i freak out on the thing and click save ok save ok save ok save ok until it takes it.

Now, however, I have been able to save each and every time.  With no delay.

Happiness abounds!
0
 
mgfranzCommented:
This needs to be taken seriously;

"WARNING: Disabling caching of file handles may seriously impact the performance of your Internet Information Server computer. Use this workaround with caution. "

I NEVER do any editing on the server files, I use a mirror site to make changes, then FTP the files later...
0
 
tzaradCommented:
Maybe it's better to use another server for working and use Site Server Publishing between the work site and the production site. This is the way I work and this allow staging and testing before sending to production.
Site Server is free as far as i know you don't need the commerce edition for publishing and you can use filter to not publish the potentialy dangerous _vti_cnf/* ...
It's just a comment ;°)
0
 
nettromCommented:
here's another one, and Microsoft simply says it's a known problem with IIS.  They didn't supply a fix in this case (which is odd, in my opinion).

http://support.microsoft.com/support/kb/articles/Q184/9/56.ASP

0
 
OcchioAuthor Commented:
Adjusted points from 200 to 250
0
 
OcchioAuthor Commented:
Sorry about the delay in getting back here. I tried the registry settings that you sent my may hkmdj and they worked great. I heed your warning mgfranz, but mirror the site costs money - I get paid alot because I can save money - not spend it : )

Thanks again hkmdj, I increased it 50 pts cause I totally spaced coming back here and accepting your answer!
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 4
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now