Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 274
  • Last Modified:

riptide soundcard

Have Hp 8575c pavilion with Rockwell modem  and riptide soundcard,have had trouble since purchased. Went to Hp forum they said to down load rippc99na update,which I did after I installed this, lost sound and modem. Called Hp support after an hour they had me run recovery only.lost everything printer ,scanner,quickbooks
,which they said I would not. After this they said this update did cause problems with some models.Can I remove this sound card and install some other sound card and leave the rockwell modem
or am I stuck with this?Has anyone had trouble with this rockwell soundcard?
Thank You
Robert
   
0
bj123
Asked:
bj123
  • 2
1 Solution
 
tjoinerCommented:
I did a little searching of the newsgroups and it appears that this modem/sound card combo is lots of trouble under Win98, and Win2000 won't even recognize it.

One option would be to disable the sound part of the card, and add another sound card to your system. You'll have to check your manuals to see how this is done... it's either with a software tweak or by a jumper on the card itself.

Or, you can disable the modem part of the card and continue to use the sound part of it, and purchase another modem for your system, preferrably a hardware modem, not a software-based "winmodem".

Or, take the card out totally, and go buy a new sound card and modem card.

Seems to me though, that if the sound and modem have given you trouble from the beginning, I'd be talking to HP about getting some warranty service on it, assuming you've had it less than a year. If the system is out of warranty, my personal preference would be to continue using the sound part of the card and purchase a better modem.

Give us more details, if you will, on what kinds of problems you were having.
0
 
sandman97289Commented:
bj123, Rockwell HCF modem + sound cards have a lot of problems as stated by tjoiner. Here is the root of your problems :Because the Rockwell HCF modem is partly software-controlled, it emulates certain chips that are found on hardware-based modems. One such chip is the UART. Windows sometimes misinterprets the UART the HCF is emulating, causing side effects like disconnections.

The HCF modem has different characteristic than Rockwell's hardware-based (ACF) modems. For reasons we don't understand, it retrains much more aggressively, sometimes causing it to become unstable and disconnect. New drivers may fix the problem, or you may try limiting it's upper speed or disabling 56K entirely.
(Taken from http://support.supernet.com/winmodem.shtml#HCF)

There are three solutions to this problem. First one and the safest is to fix the UART. To do this follow the following intructions:
Click the Start Button, choose Settings, and select Control Panel.

Double-click the Modems icon, then click the Diagnostics tab on the "Modems Properties" window.

A Rockwell HCF 56K Data Fax PCI Modem (or something similar) should appear on the list. Click and highlight the COM port assigned to it (COM1, COM2, etc.), then click the More Info... button.

After several seconds, the "More Info..." window appears. About one-third of the way down, Windows lists the modem's UART chip. If the number contains "8250", you need the UART fix. Continue with the steps below.

CLick OK on the "More Info..." window, and click OK again on the "Modems Properties" window.
 
 
In the "Control Panel" window, double-click the System icon, then click the Device Manager tab on the "System Properties" window.

Double-click the Modem icon in the list of devices.

You should see a Rockwell HCF 56K Data Fax PCI Modem entry (or something similar). Double-click on it.

On the "Rockwell Properties" window, click the Resources tab.

Uncheck the box for Use automatic settings. For the Setting based on: option, change the current configuration (normaly Basic configuration 0000 to 0001. If 0000 is not the default configuration, make a note of the default, then change it to one of the other configurations (0000, 0001, 0002, etc.).

Click OK, then click Yes on the warning window. Restart the computer.

Perform Steps 6 through 11 again, making sure that Use automatic settings remains unchecked. Change the Basic Configuration from 0001 back to 0000, or back to the original configuration.

Click OK, then click Yes on the warning window. Restart the computer.

The UART problem should now be solved. To confirm this, follow steps 1 through 4 above, and confirm the UART number has now changed to "16550". If it has not, begin with step 6 and try the procedure again. (Taken from http://support.supernet.com/hcffix.shtml)

The second fix (if the above doesn't help) is to update the drivers, which is seems you already have done with apparent problems.

The third fix is to manually configure your modem by adding some modem strings to it. To do this go to http://support.supernet.com/initstrings.shtml and look at the Rockwell modem strings to add. Try decreasing the speed of your modem and forcing V.90

I hope this helps :)

Sandman
0
 
bj123Author Commented:
thank you

robert
0
 
sandman97289Commented:
No Problem, glad to help :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now