Solved

could not open default font 'fixed'

Posted on 2000-04-10
10
542 Views
Last Modified: 2013-12-03
I just upgraded a computer from RedHat 6.0 (whose Xserver ran fine) to RedHat 6.2.  After completing the upgrade, X now fails to work.  Xconfigurator runs, correctly identifies the card and monitor, and the test-X it runs works fine.  However, when I actually do startx, the screen blanks, then X stops and I get an error message:

failed to set default font path '/usr/X11R6/lib/X11/fonts/TrueType,unix/:-1'

Fatal server error:
could not open default font 'fixed'

The TrueType directory it refers to did not exist, I created one that was a link to the ttfonts directory in the hopes of making it work.  Otherwise, I haven't done anything to it.  Did some configuration files not get updated?  I'm not sure where to go from here . . .

-Jim
0
Comment
Question by:truittj
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 

Expert Comment

by:sultrix
ID: 2702439
Ive had a problem like this in the past.

Here are some things you may want to look at if you havn't already.

1) Review your /etc/XF86Config file for     a listing of font paths
2) Make sure all paths listed have a        fonts.alias and a fonts.dir file
3) If those files don't exist use           /usr/X11R6/bin/mkfontdir

I hope this gives you enought to work with.
0
 
LVL 1

Accepted Solution

by:
philiph_elvis earned 150 total points
ID: 2702732
I believe rh6.2 doesn't use the font server any more (xfs).  With rh6.0 and 6.1, the font server program actually makes fonts available.  The config file for this is /etc/X11/fs/config.

Now with rh6.2, I believe the static config files are used.  Check for font path listing in /etc/X11/XF86config.
0
 
LVL 1

Expert Comment

by:Ted22
ID: 2702751
Try reming out # the font path in XF86Config and see if you can startx.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
LVL 40

Expert Comment

by:jlevie
ID: 2702983
It sounds like you may have installed TrueType font support at some point in the past (probably via freetype or similar). Something in startx or what it invokes is adding the TrueType directory to the font path and when it doesn't exist you get the error. I'd suggest following the process to find where the font path is being modified and removing that definition.
0
 
LVL 3

Expert Comment

by:jyu_88
ID: 2703986
I think there's nothing wrong with XF86Config. It is just xfs (the font server) not running. It is supposed to start by rc2. But, if you are in single user mode using 'startx' to start X,  it will not be there. Try to start it first,
'/etc/rc.d/init.d/xfs start'.

been there done that :-(
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2704222
It probably isn't running, but that would because it thinks it's supposed to serve a font dir that isn't there. My experience is that that'll cause the font server to abort.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2704244
Look in /etc/X11/fs/config for the line that defines the TrueType font dir and comment it out or delete it. While you're in the file it would "be a good thing" to check the other font dir specifications to make sure that they exist.
0
 
LVL 1

Expert Comment

by:Ted22
ID: 2704605
If you just rem out the font path in XF86Config you can usually startx because it defaults to something. I had a simalar thing happen when I made users conflicting with root and other existing users and xfs would not start. It doesn't solve the problem, but moves you a step closer.
0
 

Author Comment

by:truittj
ID: 2704785
I commented out the bad fontpath lines in /etc/X11/XF86Config and it works now.  Thanks for the extra information on how RedHat 6.2's X is now handling fonts, it was something that I was having trouble figuring out by just reading the config files.

-Jim
0
 

Expert Comment

by:PearlCity
ID: 8818845
For such an error //could not open default font 'fixed'//
even a 'disk space run out' can be a reason


0

Featured Post

What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Suggested Courses

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question