[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 268
  • Last Modified:

Slow Folder Access in Explorer

I am on a Celeron 300a with 160 MB of RAM, and using a 13 gig 7200rpm ATA66 hard drive.  My hard drive has about 3 gigs free.  I am in the process of sorting and backing up the hard drive onto cdr's, but after accessing a few folders and checking their contents in explorer it begins to drag.  It can take up to 30 sec's to see the contents of a folder, or rename it.  The hard drive is freshly defragged, and scanned.  Is this a virtual memory thing?  I even get this result after shutting down all background programs.
0
4_d
Asked:
4_d
1 Solution
 
jjcontactCommented:
Various Error Messages Displayed and Slow Windows Performance When Virtual Memory Is Enabled




CAUSE
This behavior can occur if the Win386.swp file located in the Windows folder has its file attributes set to read only. Windows uses the Win386.swp file to create virtual memory.



RESOLUTION
To resolve this issue:

Click Start, point to Find, and then click Files or Folders.


In the Named box, type win386.swp.


In the Look in box, click Drive C, and then click Find Now.


Right-click the Win386.swp file, click Properties, and then click to clear the Read-only check box.


Click Apply, and then click Close.






 
0
 
Patricia Siu-Lai HoCommented:
4_d, try to see if you've installed the MsOffice and has been enabled the FindFast. Go to the Control panel, click the FindFast icon to open it. Unchecked the option [x] Run when I log on to [ ] Run when I log on.
Restart computer.
Go to the command mode, at C:\ prompt, type "scanreg /fix" without the quotation. OK to run per instruction.

Run scandisk too.

Then restart the computer. See if it is now running faster to open/access windows explorer and My computer.

let me know if it worked.     pslh
0
 
elmerpevidalCommented:
Have you tried disabling memory resident programs?  Have you ruled out the probability that maybe it is caused by new installed program and it is causing conflict to system resiurces.
Have you tried looking at what other programs may be running at the same time your accessing the folders (you can look at it by pressing crtl.alt.del)?
Try disabling all start up programs and closing all other programs, except the Win OS. Then, try opening a folder and see if gets a little bit faster.  You can rule out by this process which causes the system to slow down.
If all, you can't, try installing a new anti virus.

Hope everything turns ok now.

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
adam8Commented:
firstly are you running windows 98.
If you are i think i may know what is going wrong.
0
 
4_dAuthor Commented:
Attributes were not set to read only.

Thx.
0
 
4_dAuthor Commented:
Attributes were not set to read only.

Shut down FindFast, ran
"scanreg /fix", and had recently run scandisk.  All to no avail.

As far as TSR's/memory-resident-programs, that's what I meant by "after shutting down all background programs."

I am running Win98SE.  I want to also mention that this problem was only present in Explorer, and not when I tried using Winfile.exe (the win3 FileManager) to sort my directories/files.  [The only problem is that if you move a folder/file with WinFile it is renamed in the truncated and old '8.3' format.  This only created more work for me when I had to rename all of these folder/files.]

Thx.
0
 
israelyCommented:
Goto Explorer right click on c: [Disk Clean UP] check all boxes and click ok.

[control panel][system][performance][virtual memory] select let Windows manage VM, since you are low on HD space.
Cancel reboot option.

Select [performance][file system] set typical role to <network> [ok], even though you do not have a network setup this will improve you performance.

Reboot, press and hold F8 key just before splash screen.
Select Command Prompt, to boot up in DOS mode only.
Cd to c:\windows, delete win386.swp, *.pwl and ShellIconCach, the third file has no extension. Reboot.
The three files you deleted will be recreated by windows.
0
 
jjcontactCommented:
It is like you have a memory leak.  Are you running a beta version of Windows 98?
0
 
jjcontactCommented:
I have been keeping an eye out. It may be caused by FAT32 (do you have that) and very large directories (> 32K). The fix is to move some to another folder.

http://support.microsoft.com/support/kb/articles/Q153/1/14.asp?LNG=ENG&SA=ALLKB&FR=0

0
 
4_dAuthor Commented:
Cheers! (and thank you, thank you, thank you!)

I had searched their support pages, but missed that article.  All of these folders were kept in 'My Documents' and sub-directories of it, and moving the subs to the root solved the problem.  Seems kind of weird that Explorer works that way, but I'm happy to be rid of the headache.
0
 
jjcontactCommented:
Isn't it weird at the knowledge base how you can search and find nothing but fall on the very article you need while looking for something else? I was looking for folder options at the time. I sure do love it when everything is working well.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now