Solved

Problem with Windows98 and HD?

Posted on 2000-04-12
20
292 Views
Last Modified: 2013-12-28
The past few days I had a huge problem: Every now and then (interval fo 5min or so) my computer stops working under W98. The HD led is on, and sometimes I get the error message "Unable to write to C. Data or files may be lost". I have to restart (by pressing the reset button) the computer, but even then sometimes it does not find my secondary h/d which is a Creative 52x CDROM. I have to switch it off and on again. THe CDROM and HD are on the same cable as primary & secondary.

I have scandisked my hd thoroughly and nothing comes up. I reinstalled the Windows (format + reinstall) but still the same thing happens. I am strarting to wonder whether it is my hardware, but what? motherboard or hd?

Any help with this?
I give anything
0
Comment
Question by:dinosaurus
  • 7
  • 2
  • 2
  • +8
20 Comments
 
LVL 3

Expert Comment

by:MikeRenz
ID: 2707195
try running Disk Defragmenter, and in settings, check off 'check drive for errors'


Start > Programs > Accessories > System Tools > Disk Defragmenter....in case you are unsure where the program resides
0
 
LVL 3

Accepted Solution

by:
boom23 earned 200 total points
ID: 2707390
Have you tried puttin your HD on 1st IDE cable and your cd-rom on 2nd IDE cable? I would recommend this. Also if the DMA box is ticked for your HD, untick it. Goto system properties -> device manager -> disk drives -> select your HD and in settings tab there should be DMA option there.
0
 

Expert Comment

by:gspauldi
ID: 2707453
I once had a similar problem with an older system.  It turned out to be a thermal problem causing intermittent hardware problems.  On the advice of a friend, I opened up the box and cleared the cobwebs out (literally).  Using a small handheld vacuum (specifically designed for this purpose - go to radio shack) clean all ventilation holes, including those on the power supply, and especially the heatsink on the cpu.  Clean all the fans and make sure they are working properly.  This procedure should be done at least once a year - more often if you own a cat!
0
 

Expert Comment

by:Rouscou
ID: 2707883
if you have an Soundcard installed than please take the Card out and try to boot up your System, if its booting in to the normal Operation mode than you should change your IRQ's setting.
if you aint got an soundcard and the problem still contniues than try to put your CD Rom Drive on the second IDE Contr. and try again.
if still the probl. persist try it to go inside your BIOS and select the BIOS option back into the Default options, and look inside your BIOS if the Plug and Play Option is been active if it's Desabled pls. Enable this selection
if the faulire still comes up than there would be a last posible Way to check
if you got an older CD-ROM install this unsted the new one just to check if the controller is bad on the new CD Rom Drive... maybe you can borrow one just to check your System from your Friends....
0
 

Expert Comment

by:Rouscou
ID: 2707926
Ohhh sorry I' forgot to ask you one Question did you ever try to boot up your SYTEM withouth the CD-Rom Drive...
and watching for the errors, if your Win98 comes up with the same errors than your HDD is bad... because if the HDD got bad Clusters than sometime it Works mostly it don't....
for help do the followings: Bootup with an DOS Boot Flopy with the Format Command on It, then after the DOS Prompt shows up like " A:\" then just type " A:\format C: /S/C"

if you don't know what the shortcut's means than type "A:\Format /?"
and a help File will show Up...other wise it stays for: /s = Systemfile
/c = mark bad Cluster it's taken a long time but afterwards you will be able to use your HDD again without failures.
0
 
LVL 1

Expert Comment

by:redhorse110598
ID: 2708201
Right-click "My Computer", "Properties" & under the "Device Manager" tab, check to see that there are no exclamation points on any of the devices?
Also, in the same area, under the "Performance" tab, does it say "Your system is configured for optimal performance" at the bottom of the window or some other messages(like: "Drive C:\ is operating under DOS Compatibility Mode")?
Let me know...
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2708285
The HEATING issue and dust/cobweb/hair recommendations sure sound like the key at first glance.

I'd be surprise if you didn't find anomolies in Device Manager in SAFE MODE; keeps happening to a number of us due to setup issues or incomplete registry updates.  Try this (AFTER CHECKING/RESOlVING ANY HEAT/DUST ISSUE):

Do normal shutdown and leave off at least two minutes

Reboot holding CTRL until menu

Select SAFE MODE

Check DEVICE MANAGER, expanding all categories.  Remove all occurrences of any duplicate entries for rediscovery ... and any erroneous or unknown devices, reboot and have your CD/Disk handy as well as any update drivers.

Asta

Choose
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2708297
Tell us also about your Motherboard and BIOS -- also is your system setup as Plug and Play Operating System = YES?  

Enough working FANS for your setup?

Does your BIOS give you information about your system's power usage to ensure you're not spiking or have disabled some of the monitor settings and don't see alerts about overheating or spiking?

Any BEEPS at startup, of so, how many and the order of the beeps (long long short short, etc.)?
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2708304
After a Windows 98 or W98SE reinstall, it is really important to redo WINDOWSUPDATE and get fixes, enhancements.
0
 
LVL 6

Expert Comment

by:1cell
ID: 2708316
my guess would be a flaky IDE controller or cable since this happens intermittently.  Try replacing the cable since you can get them for about a buck if you don't have extras lying around.

If, with the new cable, you get the same errors, move the hard drive to the 2nd IDE controller.  If this proves to solve the problem, you have a bad 1st IDE controller.  You can try reloading drivers from the mobo manufacturer but it will probably prove futile.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 6

Expert Comment

by:1cell
ID: 2708328
also, could you clarify this statement:

"THe CDROM and HD are on the same cable as primary & secondary"

You have a primary IDE with master and slave positions and a secondary IDE with master and slave positions.

What is your configuration for hard drives and cd-roms?
0
 

Expert Comment

by:cd_weiwei
ID: 2708340
First I think you had tp decide it is caused by hardware or software.
step 1:
     restart your computer and switch to DOS mode. Run some software
    such edit or something else. If it works well for a long time, then you
    are sure the problem lies in Win98 .if it is same with Win98. Then
    hardware .
step 2:
   A: Hardware problem
      take off all other cards ,include sound card, modem card(if you have)
     and cd_rom even floppy.just left hardware. Restart computer(off course,
     modify BIOS before that).If OK, try to add other part one each time....
     If not OK. mainboard or harddisk itself
  B: sofware problem
      a: change to another version Win98 or Win2000 to check if ok.
      b: check if some virus exist
0
 

Author Comment

by:dinosaurus
ID: 2709888
I am sorry for rejecting, just send comments and I will choose the best answer to award the points.

My M/B is an ASUS with Cyrix II 333Mhz. I have moved the CDROM to IDE2, and fixed some bad clusters in my HD and it seems to be working, but will be cautious for the next couple of days, before awarding points.

It worked fine with my sound card, modem and SCSI cards before, so why suddenly give me a problem?

Anyway, I will let you know soon.Thanks for all.
0
 
LVL 1

Expert Comment

by:constable
ID: 2710244
"fixed some bad clusters in my HD"

There's the problem right there!

If you're getting bad sectors, *especially* near the beginning of the drive's data table, you're going to get write errors and machine freezes.

I think although you've "fixed" the problem for now this could be a hard drive controller issue. I'd get that drive RMAed as soon as possible, and move all of your data off of it while you wait for the replacement.

Better this route than a complete crash - and that seems very likely at this point.

The CD-ROM detection issue appreas to indicate a faulty mainboard - we had a similiar situation that disappeared when the CD-ROM unit was replaced.
0
 
LVL 1

Expert Comment

by:Ted22
ID: 2710637
Try unplugging the CD and see if it makes any differance. Try a different ribbon cable to the hard drive if you have one. If you reloaded software it is hardware. By unplugging the CD you'll be sure it's not that. Same with replacing the ribbon cable.

Find out what HD you have and go to the manufacterer on the web and get their utility to check the HD. Most of them can be put on floppies.

Also if your bios supports it you could plug the HD into the secondary controler and disable the primary and try that.
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2711986
Which ASUS MB?  The P3B-F, for example, just had a BIOS update which I implemented on one system from v.1004 beta 002 to 1005.  Strange behaviors resulted, working with ASUS tech support on the issue.  Curious if when you boot in SAFE MODE you find errors and duplicates for your disk drives as well as the Hard Disk Controllers, and if you then delete all, do some primary and secondary controllers remain (dual fifo) that you cannot remove?  Perhaps some of this behavior is related (assuming all the prior recommendations have checked out).  Also, if this is the same MB, did working in the BIOS exhibit strange delays when trying to address the BOOT sub menu and the jumperless settings?

Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2712035
BTW ... have you also checked/noticed that if at first boot, not all devices are listed in the bootup splash screen, but on reboot all are found?

Any SCSIs?

This ASUS link may prove helpful to determine your Motherboard and all the BIOS releases for it.  As you read through the fixes for your BIOS, take note of the details as to which may resolve your issues.  On one of our ASUS MBs and BIOS versions, one of the IDE related errors was Fix a 40-pin IDE cable is detected as an 80-pin one.


http://www.asus.com.tw/Products/Motherboard/

for selection of your MB.

If you also have the P3B-F, here's that link:
http://www.asus.com.tw/products/motherboard/bios_slot1.html#p3b-f


Asta

0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2712040
Here's the other potentially related bios fix you'll also find through above link ... Fix IDE hard drive having a formatted partition larger than 8.4G bytes cannot be enumerated by OS in "User Type HDD" mode.
0
 

Author Comment

by:dinosaurus
ID: 2713411
It works fine now with having the CDROM in IDE2. I still cannot understand the problem. My BIOS is the most updated one, and the problem was with the system and not Win98.

Anyway thanks for all the answers... and if you can put your IDEs in different cables/controllers do so (this hints cost me 200points)
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 2719302
Well, think of it like this....bad news, cost you 200 points :0(  but the GOOD NEWS is, it only cost you 200 points.  PLUS, having been there and done that, I've also found that mostly it is:

 ... Good news!  Little $, issue fixed
 ... Learned new things for free
 ... Found people care and work to help

So mostly,

:0)

Asta
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now