Solved

Incoming SMTP Mail through MS Proxy Server

Posted on 2000-04-12
4
298 Views
Last Modified: 2013-12-18
I have a Domino 5.02a Server on a Windows NT MAchine which is behind an MS Proxy Server on another machine. The Proxy Server is the only visible IP Address (Internal Addresses are private). I have managed to set up Outgoing SMTP mail using the HTTP Tunneling Protocol and this works OK, but I have been unable to set up Incoming SMTP Mail from the Internet to the Domino Server.

Any advice?
0
Comment
Question by:dmpdmpdmp
  • 2
  • 2
4 Comments
 
LVL 2

Expert Comment

by:amit_dutta
Comment Utility
Hello dmpdmpdmp,

U can obtain ur objective by specifying ur internal ip address of the domino server in the MS proxy server's inbound settings for mail forwarding.

So that whenever ur proxy will receive any mail from the intenet on port 25, it will forward it to the domino server because of the inbounf mail forwarding option.

Hope this will help u.

Cheers
0
 

Author Comment

by:dmpdmpdmp
Comment Utility
Yes, that seems logical, but where do I actually do that? The only way I could get outgoing SMTP Working was to use the HTTP Tunneling Proxy, is there anywhere I can set up an incoming connection through the same proxy - a registry setting perhaps?

Regards,
Dave.
0
 
LVL 2

Accepted Solution

by:
amit_dutta earned 100 total points
Comment Utility
Hello Dave,

In your MS proxy goto the security tabed page and enable the packet filtering option and add SMTP. Click on the "Custom filter" and put TCP,Both Fixed Port - 25. Select the Interal Computer and put the internal IP address of the Domino server.

This process will forward all ur inbound trafic to the internal computer which u hae specified.

Hope this makes sense to u.

Thanx
0
 

Author Comment

by:dmpdmpdmp
Comment Utility
It would appear that you have to enable the Packet Filter as you have described, but also that you have to have the WinSock proxy client running with the wspcfg.ini file installed in the Domino Directory. If anyone else wants to try this setup the wspcfg.ini file looks like this:

[Common Configuration]
ServerBindTCPPorts=25
Persistent=1
KillOldSession=0

With this setup I was able to get Incoming SMTP Mail to work.

It seems to be very difficult to get a complete set of instructions for this, so thanks to you for your help and thank goodness for Experts Exchange!

Regards,
Dave Pearson
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

For users on the Lotus Notes 8 Standard client, this article provides information on checking the Java Heap size and adjusting it to half of your system RAM in attempt to get the Lotus Notes 8.x Standard client to run faster.  I've had to exercise t…
I thought it will be a good idea to make a post as it will help in case someone else faces these issues. I trust this gives an idea how each entry in Notes.ini can mean a lot for the Domino Server to be functioning properly. This article discusses t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now