• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 340
  • Last Modified:

Autosense nic fails on 3COM Smart Switch

I have an intel mother board with a Pro100 network card built into the motherboard.  (The machine is colocated - I will re-ask this question when I have all the version numbers, but just in case someone has the answer, I ask now)

When I plug into the switch, I get no lights on the nic, when I plug directly into the cabinet's plug, avoiding the switch, all is fine.  Another system running W2K Professional has no problems with either connection.

I am running RedHat Linux 6.1

1 Solution
It's probably failing to autonegoiate. There are options that can be used to set the card's mode (see http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html). Also there are some diagnostics progams available from the same page.

Probably not an issue, but there is a known problem with the Intel PR440FX MB with both Adaptec 2940 & the Pro100, see the not on the above page if you have that problem.
griffinwerkAuthor Commented:
Thank you, this is the information I was looking for.  Either the options to force the card to 100MB duplex will work or it won't.  If it does not, I won't, I'll get another card. Thanks also for the quick response.
--Hank Ratzesberger
Griffinwerk Productions
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now