Solved

Netscape and transparent GIFs in tables

Posted on 2000-04-13
23
301 Views
Last Modified: 2011-08-18
I've got a table in which I'd like to set the background in individual cells. I'm using <TD BACKGROUND="image.gif"> but when my image is a transparent gif the image fails to show in Netscape.  It works OK in Internet Explorer.  

You can access an example of the problem at

www.marvellousnews.com/tabletest.html

Could this be a problem with transparent GIFs generated from Paint Shop Pro?

0
Comment
Question by:carldean
  • 11
  • 11
23 Comments
 
LVL 7

Expert Comment

by:nettrom
ID: 2710995
worked as it should in both NC4.72 and IE5 here.  image came up and displayed as it should.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711118
What did you see in the table's third row?  Did you see the image on a red background?

I'm also using NC4.72 and I don't see it.
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711151
yep, image on a red background.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 1

Author Comment

by:carldean
ID: 2711186
Well isn't that weird!  So perhaps it's something to do with my configuration of Netscape.  I did a "Typical" install from the CD and I've added a proxy but I've not changed anything else.

How is your Netscape configured?  Are there any options to do with images and transparency?
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711209
shouldn't be anything in particular.  I have "Automatically load images" checked under "Edit, Preferences" then "Advanced".  it's more or less a default Netscape installation, but with smaller toolbar buttons (I don't use the text labels), and underlining of links turned off.
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711218
forgot to add some things:

as far as I know Netscape Communicator/Naviagator doesn't have any particular settings for transparency.

and I don't have a proxy server.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711249
"Automatically load images" is the default and I have that set.  I've removed the toolbar labels and the link underlining (because you never know!) and as expected that has made no difference.

As for the proxy server I still get the same results through my dial up account so that's got nothing to do with it.

I'm baffled.
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711271
what happens if you try to load the image directly by typing in the right URL?

maybe it's a cache problem, try clearing both the memory and disk cache through "Edit, Preferences" then open "Advanced" and choose "Cache" and hit the buttons for clearing the cache.

also, what is the setting for "Document in cache is compared to document on network"?
0
 
LVL 2

Expert Comment

by:burntout
ID: 2711272
I know that some an older version of netscape will not let you set a background image for table rows or cells
only the whole table, the newer browsers you can set an image for each cell.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711285
Well I'm using 4.72 as is nettrom - that's pretty up to date I think.

The problem is that we are both experiencing different results.  This makes me think that there's a problem with my setup.  My first thought was my display setup but I've tried it in 256, 65536 and True Colour - all to no avail.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711292
netrom

If I load the image directly...

www.marvellousnews.com/transgifimage.gif

then it is loaded and displayed with a transparent background.  The problem only occurs when the image is a background to a table cell (<TD>).

Still baffled.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711304
netrom

I've cleared the cache (both memory and disk), "Document in cache is..." is set to "Once Per Session".  But after clearing the cache this is irrelevant.

Still no joy.  I wonder if it's only me?  I could live with that!!!

0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711403
can you access the page without the proxy?  does the image come up then?
0
 
LVL 1

Author Comment

by:carldean
ID: 2711424
I've just tried it again from my dial-up account (which doesn't use a proxy) and I get the same results.

What operating system are you using? I'm on NT4 with Service Pack 6.
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711454
Your proxy-configuration is dynamic, so it updates itself depending on whether you're using a dial-up account or something else?  Sounds cool...

System settings:
Windows 98, First Edition.  128MB RAM, Matrox G200 AGP with 8MB RAM on it.  Quite up-to-date drivers, 1280x960 @ 32bit resolution.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711471
Sorry, my proxy configuration isn't dynamic.  I've just got two machines.  One on our company network that accesses the internet through a proxy and my laptop that has a modem.  Not so cool I'm afraid!!!

Anway as for your setup I'm now wondering if the problem arises because I'm running Netscape on NT!

Unfortunately I don't have access to a 95/98 machine at work.  I'll install Netscape on my 98 PC at home and give it a try.
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2711523
I bugged one of my colleagues here at work who run NT4sp6 and NC4.72, and she experienced the same bug that you do.  Seems that NC4.72 on NTsp6 doesn't like transparent GIFs as background images in table cells.

We haven't had the time to research it further though.
0
 
LVL 1

Author Comment

by:carldean
ID: 2711533
nettrom you're a gem.  All I need now is a workaround!!!
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2712307
I'm unable to fix that since I'm at work right now, but I'll see what I can figure out when I get home in a couple of hours.  Am running NT4sp5 there, and hopefully I'll see the bug there too.
0
 
LVL 7

Accepted Solution

by:
nettrom earned 100 total points
ID: 2712960
Am home, tested with NC4.70, and the problem remains.

I did some searching for this on the web and on Deja News, but didn't find anything really useful.

I did find another page with the problem though, from a post on Deja News: http://www.net-com2000.de/de/start.htm

I checked it out in Netscape, and noticed that in _some_ of the table cells the transparent background did show up.   I therefore tested your page a bit further, and I found that the GIF is shown as long as the table cell width is below a certain size.  It also happened that Netscape didn't show the GIF upon first loading, but if I tabbed to another application and then back to Netscape, the GIF would show up (as the background of the cell).

So it seems that we've found a display bug related to transparent GIFs on Windows NT.  I checked the problem with a DIV too, and noticed that the bug also happened there.  It leads me to believe that Netscape has a problem showing transparent GIFs as the background of elements other than BODY.
0
 
LVL 1

Author Comment

by:carldean
ID: 2714949
nettrom,

I would have to agree.  I've sent a bug report off to Netscape so we'll have to wait and see what happens.

In the meantime I'll just have to do something else I suppose.

If you stick some sort of answer in nettrom then you can have the points.  While I've not got the answer I hoped for you've certainly worked hard enough to justify receiving them.

Cheers, Carl.
0
 
LVL 1

Author Comment

by:carldean
ID: 2714958
Ooops, I didn't realise you could accept a comment as an answer!!!

Once again, cheers nettrom. (see previous comment for full acclamation!)
0
 
LVL 7

Expert Comment

by:nettrom
ID: 2719179
thanks, glad I could help you out.

I don't think Netscape will do much to fix the problem in version 4, instead they'll probably make sure it works in the upcoming Netscape 6 (which builds on the results from the Mozilla project).  I noticed that it too has some problems, it didn't tile the JPEG background correctly, but that may be already in the bug database destined for fixing.  If you want to test it out yourself, fetch a build of Mozilla from http://www.mozilla.org/
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article discusses four methods for overlaying images in a container on a web page
Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
In this tutorial viewers will learn how to embed Flash content in a webpage using HTML5. Ensure your DOCTYPE declaration is set to HTML5: "<!DOCTYPE html>": Use the <object> tag to embed Flash content.: To specify that the object is Flash content, d…
The viewer will the learn the benefit of plain text editors and code an HTML5 based template for use in further tutorials.

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question