[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2784
  • Last Modified:

rcp permission


I have two solaris machines A, and, B, both have the account "accnt" established.

The .rhosts at A:~accnt has the following line:

    B.powertv.com  accnt

The .rhosts at B:~accnt has the following line:

    B.powertv.com accnt

I am able to do the following on A

     rcp test.txt B:~accnt

But if I try the corresponding one on B

     rcp test.txt A:~accnt

I got "permission denied"

Any idea where to look for the configuration problem ?

Thanks !!

Vincent

0
vincentlue
Asked:
vincentlue
1 Solution
 
tfewsterCommented:
> The .rhosts at A:~accnt has the >following line:  B.powertv.com  accnt
- So A trusts rcp/rlogin from B

> The .rhosts at B:~accnt has the >following line: B.powertv.com accnt
- So B trusts B (Why?)

>I am able to do the following on A
>rcp test.txt B:~accnt
- As B hasn't been setup to trust A by .rhosts, it must have been set up in B's /etc/hosts.equiv

>But if I try the corresponding one on >B: rcp test.txt A:~accnt
>I got "permission denied"
- If just the .rhosts is set, this should work. However, if B has been specified as UNtrusted in A's /etc/hosts.equiv with -B, the .rhosts file won't override it.

Further, rcp/rlogin to A may have been disabled in /etc/inetd.conf

Another possibility is if the hostnames of the machines are just A & B instead of ?.powertv.com - I can't remember if rcp authentication goes on the hostname or the IP address



0
 
encilarCommented:
tfewster is right !!! For simplicity, just do this entry for both .rhosts of both machines...

The .rhosts at A:~accnt should have the following line:
B.powertv.com  accnt

The .rhosts at B:~accnt should have the following line:
A.powertv.com accnt

I'm pretty sure this would work for rcp, rsh, rlogin, etc.
0
 
jacquesc030600Commented:
Hi,

you should edit two files in each system

On system A

nodename of machine A and B

vi /etc/hosts



exemple

ComputerA   192.9.200.1
ComputerB   192.9.200.2

And in the file /.rhosts on each one the nodename of the other computer

On the computer A

vi /.rhosts

computerB

On the computer B

vi /.rhosts

computerA

It should work


0
Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

 
tfewsterCommented:
jaquesc, /.rhosts is the file to allow rlogin by root (which is NOT usually a good idea). Please convert your answer to a comment.

vincentlue, one additional test is to try rlogin from B to A; If you are prompted for your password, but then allowed in, this would confirm that there are no other networking/security issues, e.g. if the hosts are on opposite sides of a firewall. Also, double check .rhosts is owned by user accnt.

BTW, I may have been wrong about .rhosts not over-riding /etc/hosts.equiv - It does under HP-UX!
0
 
vincentlueAuthor Commented:

Sorry to take that long to respond to
your help.

There is a typo my original question.
It should read as:

The .rhosts at B:~accnt has the following line:

    A.powertv.com accnt

As many of you have figure out.

I checked inetd.conf and hosts, both machines are pretty much the same. There is no host.equiv setting.

I try "rlogin", yes, one goes through
without asking password and the other
does ask password and allowed in afterwards.
0
 
tfewsterCommented:
Hi Vincent - that SHOULD work! Just to restate & summarise the other tests:

(A trusts B - but B$ rcp test.txt A:~accnt fails)

Check ~accnt/.rhosts on A is owned by user accnt.

Are there any "-" entries in /etc/hosts.equiv on A? (Even so, the Solaris
7 man page for hosts.equiv says .rhosts should override this)

As a temporary test, edit /etc/hosts.equiv on A to put B.powertv.com as
the first line in there.

(Forget what I said about inetd.conf, if rsh and rlogin were commented out
you'd get a "Connection refused" error instead - Sorry!)

Try "pulling" the file, instead of "pushing" it by doing:
B$ rcp A:~accnt/test.txt .
to make sure it's not a write permission problem.
0
 
ianBCommented:
We have opened up a new Solaris Topic Area.  

To increase the visibility of questions, we moved questions we felt
appropriate to the new Solaris Topic Area where they will be easier for
Solaris experts to find and answer. You may view your question at
http://www.experts-exchange.com/Computers/Operating_Systems/Solaris/ 

If you have any questions about the new topic area you can contact
Community Support by posting a comment at the following URL or by
emailing us at cs@experts-exchange.com.
http://www.experts-exchange.com/Customer_Service/Experts_Exchange/ 

Ian
Community Support @ Experts Exchange

0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now