Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 274
  • Last Modified:

Time format Access and mail merge

Greetings To All
===========

I keep a database of club details which includes meeting time as a "Short Time" field and appears as 18:30. I also use the 24hr option.

Amongst other things I use the data for mailmerge in Word2K and the time is then displayed as 18:30:00

What can I do to remove the seconds?

Many thanks,

robinski
0
robinski
Asked:
robinski
  • 3
  • 2
  • 2
  • +1
1 Solution
 
nico5038Commented:
Did you try to change the timeformat in the regional setting in the configuration window?
0
 
brewdogCommented:
Are you using the table itself as the record source for the mail merge? What about basing a query off the table and putting this for your time field:

CStr(YourField)

I'm not a machine with Access right now, so I can't guarantee it would work, but . . . it would convert it to text rather than letting Word read the stored time value.

Hope this helps . . .

brewdog
0
 
repsteinCommented:
You need to fix this from the Word side, not the Access side.

1. In your mail merge source document, go to the time fields that are not displaying properly. The will look something like <<meetingtime>>

2. Right click on the field and select toggle field codes

3. If you haven't done anything to the field, it will probably have a part that says \* MERGEFORMAT

Replace this with \@h:mm
If  you want am and pm to show, replace it with
\@h:mm am/pm

If you want the leading 0 to show in the time with AM or PM, replace it with
\@hh:mm AM/PM

Hope this helps.

Richard
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
nico5038Commented:
repstein,

Just out of curiosity:
Is the \* MERGEFORMAT referring/using  the regional settings ?
0
 
repsteinCommented:
nico5038:

\* MERGEFORMAT is a switch that maintains formatting directly applied to a field in Word. As best as I can tell, it sometimes is needed, and sometimes is not. If formatting is lost in the mailmerge document, then it needs to be added. It's automatically applied by Word when a field is inserted and Preserve formatting during updates has been checked in the Field dialog box. If you want to use a picture switch (such as \@ for times), this needs to come before the \* MERGEFORMAT switch).

It doesn't have anything to do with regional settings.

Richard
0
 
robinskiAuthor Commented:
restein

Many thanks. Your technique certainly removed the seconds but I use a 24 hour clock. Is this possible?

robinski
0
 
repsteinCommented:
\@ H:mm
should do the trick.

Richard
0
 
robinskiAuthor Commented:
Thanks very very much.

robinski
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now