sound and modem conflict

I use mandrake 7.0, and I had to reinstall it.  The modem and sound was working fine before I had to reinstall.

Now, I configure my connection to the internet, which works fine... then I configure my sound.  Sound works fine, but now I get a modem is busy error when trying to connect to the internet (I use sndconfig and kppp).  I think I did everything I did before to get them to work.  Any suggestions? Thanks.
diotharAsked:
Who is Participating?
 
x25Connect With a Mentor Commented:

 if both are ISA, then the problem - for sure- is in that isapnp.conf

 Try Renaming it as i stated first, don't use the .bak extension.

 That worked for me in RH6.1
 That time i had:
 Creative Modem Blaster V.90 ISA
 SoundBlaster 64 bit ISA

X.25
vicer1@yahoo.com
0
 
jlevieCommented:
What modem (internal make/model, or external), what sound card and what IRQ's are each using?
0
 
diotharAuthor Commented:
I never had to bother with that earlier.
modem is the typical 56K us robotics modem, irq 3. soundcard is the crystalwave fusion whatever... whatever... irq 9.  Both are seen by the computer.  
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jlevieCommented:
Is the bios set to disable the onboard serial port that normally would use IRQ3 (COM1)? If not, the OS has probably decided that the serial port is present this time, and it has the IRQ. If the IRQ's are as you've indicated, there's not a conflict between the soundcard and the modem.
0
 
diotharAuthor Commented:
I think it has something to do with isapnp.conf and my pnp soundcard.
I have not changed any settings on my bios since I reinstalled linux, this is a new problem for me. I normally don't have it.
0
 
x25Commented:
i had this problem before (with RH6.1)
it's the /etc/isapnp.conf

 is your modem inside or outside (internal/external) ?
 and if it's internal, is it ISA ?

 is your soundcard ISA ?

 Try renaming isapnp.conf, setup sound, them modem, in the same order.

X.25
0
 
diotharAuthor Commented:
modem and soundcard are internal.
lothar says the soundcard is alsa.
the modem is just a generic us robotics 56K x2 modem (that I flash updated the rom to a V.90)  (so, I guess it's a v.90 now)

I will mess with the isapnp.conf and see what it does.  isapnp was my problem last time when I could not get the sound to work, also.  I had to comment out some lines that was giving sndconfig an error do not know what to do with 3,5,7, or 10).  that fixed it the first time.  Perhaps just deleting it or copying it will fix it the second time.
0
 
jlevieCommented:
I suspect that you need a more systematic approach, so as to have a repeatable process. There are man pages for all of the pnp tools, that you probably ought to look over, but I'd start by running pnpdump to see what's being ID'd and where it want's to be. As noted in the manpage for pnpdump, it's output can be used (with suitable editing) as the input file for isapnp.
0
 
diotharAuthor Commented:
thanks. worked.
actually, out of frustration, I just deleted the sucker. :P  still works.
In fact, I am typing this on linux listening to jimi hendrix. :P
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.