Solved

Can't Copy File from A: To C:, But Can Open It

Posted on 2000-04-16
14
618 Views
Last Modified: 2013-12-28
I have a Powerpoint (.ppt) file on a floppy disk.  It's size is 684K.  On my desktop computer I can put the disk in A:Drive and open the file by double clicking on it and PP opens and the data file loads and I print and work with the file fine.  When I tried copying the file (various methods, dragging, copy/paste, etc.) to the C: or hard drive, it started to copy and then I got an error saying something to the effect "the system cannot read from the specificed device".  My question: if the file was bad on the floppy disk, or the floppy disk was bad, then I wouldn't be able to open the file, right.  So why can I open the file but I can't copy it to the hard drive?  Also, when I tried to do a "Save As", after loading the file into Powerpoint (thinking I could save it to the hard drive that way), I got an error message and it wouldn't let me??  I checked the floppy drive and the hard drive, they work fine because I tested them using other floppy disks and files.  Also, as further info:  This file that's on the floppy disk I wanted to attach to an email, so I took the disk to my portable computer and tried to do that.  It wouldn't let me - got an error message here also?  Obviously there is something wrong with the file or floppy disk, but why then will it open fine into Powerpoint?  Also, why couldn't I do a "Save As".  If the file is loaded into memory and the whole PP presentation is up on the screen you would think it would let me do a "Save As" to a different drive and directory (I tried to save it in a new folder on the hard drive, and even tried a different file name - none of this worked??)
Thank you,
Joe Boyd
0
Comment
Question by:JoeBoyd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +4
14 Comments
 

Expert Comment

by:john
ID: 2721434
Try right clicking on A drive and do a copy disk from A to A


Do a scandisk on A and virus check

0
 
LVL 1

Expert Comment

by:LadyKath
ID: 2721481
If you copy from a to a, you will be copying the same file over itself and you are trying to get the file to your hard drive, correct?
What was the error message when you tried "save as"? Are you the creator of the Powerpoint file and the file itself, was it copied from another system to the floppy?
0
 
LVL 7

Expert Comment

by:sorgie
ID: 2721506
Just for a test have you tried copying it to your C drive in dos mode??
0
Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

 

Accepted Solution

by:
john earned 60 total points
ID: 2721527
I meant do a disk copy from A  to another floppy of course if you can
then you will at least have a backup before you run scandisk
not that scandisk will do any damage, just to be sure


Check the microsoft site they have utilities for fixing word , excel ,and PP
files etc

0
 

Expert Comment

by:dandk98
ID: 2721625
It sounds as if the floppy disk is dieing try this
make a temp directory
open a dos prompt
type copy a:\*.* c:\temp
and then cross your fingers and hope
Dave
0
 

Author Comment

by:JoeBoyd
ID: 2722720
LADYKATH:
1.) The "Save As" message was as follows: "There was an error accessing the disk containing C:\test\"name of file".ppt.  Note: I have done numerous test on the hard drive (it can copy and xfer files fine, open programs, etc.).  I notice when I try to save it to the C: hard drive I get a lot of activity on the A: drive.  Why is this?  I thought once I loaded it into Powerpoint the A: drive was more or less out of the picture (especially if I was saving it somewhere else?).  A side note: it take 2 trys to load the program, so maybe the floppy is dieing.
Please answer the tech. question though of why Win 98 works this way (eg. opened up file in application can't store to hard  drive if floppy bad?
2.) No, I was not the author.  We received the file as an email attachment on my wife's PC at her work (which is a Win 95 PC).  I unattached and saved it to her hard drive fine.  I then took a new floppy disk and copied from her hard drive to this floppy disk and took it home to my PC.

JOHN:
I did try a diskcopy to a new disk; same problem.
I tried the Scandisk, used the "Through" option, following is first message:  "Could not properly read from or write to cluster 332, which contains some or all of the "file name" file.  The contents of this cluster are probably already lost"
I clicked on Repair this cluster. Continued to run; did not get any more errors.  When finished it said it found errors and fixed them (512 bytes in bad sectors). When I tried to copy it in Win 98 (drag and drop), I got the same kind of error message as before "the system cannot read from the specified device".  BUT, I could still open the file from the floppy disk into PP and my whole presentation seemed to be there?

SORGIE and DANDK98:
I tried copying it to C: drive in DOS Mode, copying it to a temp directory.  Got error message "Read Fault error reading drive A.."

EVERYONE:
Please read all comments to all of you -thanks.  I realize now that I'm sure the floppy disk is, or was, bad and probably damaged my file, but, I still have some questions please:
1.) I guess it appears I did have a a bad sector and even though Scandisk fixed it, I still lost the data, correct?
2.) But, why can it seemingly open the file fine into PP and everything seems to be there, but I can't copy it anywhere.
3.) Why, once it's loaded into memory in PP can't I do a "Save As" on the C:Drive.
Please explain; I'm a little confused.
Note:
I will award points accordingly to the explanations I get even if I have to repost a question directly to you all to give you the points you deserve.  I like to treat every one as fair as I can,because I REALLY APPRECIATE your time and help.
Thanks,
Joe Boyd
0
 
LVL 5

Expert Comment

by:jjcontact
ID: 2723370
When you have the presentation open and running well and do a "save as" to the C drive, have you tried a slightly different name?
0
 

Author Comment

by:JoeBoyd
ID: 2724017
JJCONTACT:
Yes, I have tried a slightly different name.  What I find extrememly interesting is that I would of thought that instantly it would save it to the C: hard drive with no floppy drive activity.  But, even saving it to a folder on the C: hard drive the floppy drive still starts up and spins first.  It's almost like part of the file is still on the floppy yet?????
Joe
0
 
LVL 5

Expert Comment

by:jjcontact
ID: 2724075
If you don't have and can't get another copy of this file, you can go to Powerquest and try a demo of Lost and Found to see if the file can be rebuilt. Or you can demo the most recent Nortons which, according to some of the experts here will work about 50% of the time.
I have had this problem, not that I know what goes wrong, but usually, I can get it to copy to another disk by changing the name. I have even saved it as a file of another extention type and then changed it back once I got it copied over.. How about changing the PPT file slightly and then trying to save?
0
 
LVL 5

Expert Comment

by:jjcontact
ID: 2724095

Is the floppy disk active only when working with this file?
See:
http://support.microsoft.com/support/kb/articles/Q216/7/52.ASP?LNG=ENG&SA=ALLKB&FR=0
0
 
LVL 5

Expert Comment

by:jjcontact
ID: 2724098
Do a find for *.tmp files and delete them. You may be working with the same corrupt temp file each time.
0
 
LVL 5

Expert Comment

by:jjcontact
ID: 2724128
Also, there were some major changes in file formats from OFFICE 97 and the Service Releases. What powerpoint are you running and has it been updated by SR1 and SR2 and do you know what version the guy you got it from is using?  Here is a small amount of information from the SR1 information file from Micrsoft.

Why did Microsoft change the file formats in Office, knowing this could cause migration or compatability problems?
File format changes were required to deliver rich new features such as in-document hyperlinking, drawing capabilities with OfficeArt, greater charting ability in Microsoft Excel and a common programming language across Office 97. Microsoft is always concerned about the impact file format changes will have on customers and has introduced tools to help you manage the transition. In addition, Office applications are designed to make moving to new versions a smooth and seamless operation.


0
 

Expert Comment

by:lazer1
ID: 2724988
When you open a presentation, it should create a temporary file copy of it. If you leave the presentation for X ammount of time say 1 hr, powerpoint should itself try and copy the contents of the ppt into a tmp file located in C:\windows\temp.

On another note, take the disk out make sure its not write procted. Move the silver disc in the middle of the floppy 360 degrees, give it a bit of a hit, and place it back in the floppy drive.

0
 
LVL 1

Expert Comment

by:LadyKath
ID: 2725288
Joe,  
1) yes, whatever data was saved to the cluster is lost, however it as you have observed is not necessarily the data actually displayed in the presentation, it could be anything from format information to a font. Frankly, I'm surprised you have been able to pull up the presentation since you
Try this as a possibility, instead of "save as" try "send to" and attempt to send your file to "my documents".  Though I am skeptical at this point as the bad cluster is what has and is inhibiting you from saving the file to your system.
 As a side thought, do you know anyone with Norton's Disk doctor, maybe this software can recoup your diskette enough for you to have a salvageable presentation?
The data that was stored in the bad cluster definetly is impacting your ability to copy it to anywhere and I can't help but wonder if this is a built in "safety precaution". (By the way do you think the original diskette was bad or is there a chance someone's floppy drive is going out or has a head alignment issue) Any chance of getting the file to the floppy drive that copied it and see what happens?(Of course the disk has been altered by scandisk) If there is and it opens the file without a hitch maybe from there it can be emailed to you.
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Which Windows settings change when I join a domain? 12 37
VMWare 101 9 101
Server error: '550 5.7.1 Unable to relay' 2 30
Seeing Who Changed Files in Windows 1 58
No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
This article summaries thoughts and ideas from two years of sustained use. It provides good reasoning to make the jump to Windows 10.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question