Solved

Cannot mount my CDROM

Posted on 2000-04-17
12
331 Views
Last Modified: 2010-04-20
HI,

I installed Mandrake 7.0. Works fine.
Except: I can't mount my CD.

I've looked through the information, but nothing seems to help.

This is my pc:
2 Drives on hda and hdb
1 CD (I both tried my HP Rewritable and an ordinary CD) on 2nd controler.

Now, I think it sees my drive as hdc (I'm pretty sure, I think it appeared in the boot)

But, I can't mount it.

I tried:
mount /dev/hdc -t iso9660 /mnt/cdrom
mount /dev/hdc -t vfat /mnt/cdrom
(The /mnt/cdrom exists)

I already messed with the /etc/fstab file too, tried supermount ... no cure.

He keeps telling me: not the correct fs.

What's wrong and how can I fix it ??
0
Comment
Question by:vindevogel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 1

Expert Comment

by:paulmitch
ID: 2722524
The filesystem on a cd will be iso9660, not vfat, so your second try would not have worked.

However, your first try should have.  Try another cdrom...  perhaps the disk is corrupt?

Paul
0
 
LVL 4

Author Comment

by:vindevogel
ID: 2722599
I've done that already.

First, I tried the CD that was in the tray.  That was the CD from which I had just installed the system, so not really corrupt ;-)

I've already tried different CDs, including music cds, no go ....

I think Mandrake has problems with seeing my CD as a HD (or visa versa)
0
 
LVL 7

Expert Comment

by:frache
ID: 2722687
----
login : root ? ( rights problem )
----
Verify fstab file (fstab - static information about the filesystems
)

Where ? : perhaps : /etc/fstab (?)
To find fstab file you can use command "find".
help about this command : man find


0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 4

Author Comment

by:vindevogel
ID: 2722750
login = root
fstab: /etc/fstab
0
 
LVL 1

Expert Comment

by:paulmitch
ID: 2722835
you will not be able to mount audio cds.  For some reason, there is no/and will not be an audio filesystem for Linux.
0
 
LVL 4

Author Comment

by:vindevogel
ID: 2722913
Okay, but I should be able to mount the other ones.

I just put it in as a (kind of) test.
0
 
LVL 17

Accepted Solution

by:
psimation earned 50 total points
ID: 2722938
There is a couple of other posibilities.
You CD, is it secondary slave (hdd) or secondary master (hdc), try mount /dev/hdd -t iso9660 /mnt/cdrom
Then also make sure that the /mnt/cdrom folder exists.
A further possibility is that ( because of your cd-writer) Mandrake has already done the hard work for you ( compiling the kernel for scsi emulation; the only way that you will get to write cd's with an IDE cd-writer is if the system sees it as a scsi device)
If so, all your cd-roms (writer included) will be scsi devices, and they should be /dev/scd0, /dev/scd1 etc.
so, try mount /dev/scd0 -t iso9660 /mnt/cdrom

You could also try to connect your cd-rom with your primary master disk, and then make your primary slave disk, your secondary master disk and see if linux still picks up the second hard drive. You can also just type dmesg at a prompt after boot and make sure that all ide devices are listed at boot time, if ( when you have all four drives connected) you don't see devices hda through hdd, then you know that the problem lies either with your IDE controller, or your jumpers on the cd-roms are not correct.
good luck

0
 
LVL 4

Author Comment

by:vindevogel
ID: 2723018
psimation : this could be: I used my CDWriter to do the setup.
0
 
LVL 15

Expert Comment

by:samri
ID: 2723057
vindevogel,

Try browsing through the system log file for any hints on what devices are your cdrom is attached to. /dev/hd?

if you have 2 HD on the primary controller, then you cd drive most likely will take /dev/hdc or /dev/hdd.

try mounting /dev/hdc /mnt -t iso9660 or /dev/hdd /mnt -t iso9660

or how about browsing cdrom via file manager (in kde).

good luck
0
 
LVL 1

Expert Comment

by:paulmitch
ID: 2723150
psimaton is almost certainly correct.  It'll be using SCSI emulation on the ide bus for the cdrom.

So, as psimaton suggested, try the mount /dev/scd0 ..... command.
0
 
LVL 4

Author Comment

by:vindevogel
ID: 2723342
samri : pls, read what I already tried.

psimation, paul: I will try this this evening.  If I can get on the net, I'll post another comment, otherwise, I'll post it tomorrow (during working hours).
TIA guys (girls)
0
 
LVL 4

Author Comment

by:vindevogel
ID: 2725809
psimation:

Your suggestion to check if Mandrake had compiled my kernel with SCSI was right.  He did.

Now I can appreciate his work, but not after the first boot.

My CD works fine now, tnx.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question