Bypass login screen part 2

Below is the advice I got recently on how to bypass the logon screen.  However, this seems to only work right after I make the changes in the registry.  (i.e. after I make changes, I exit regedit and then reboot.  It logs on automatically, which is good.  Then when I reboot again, it pops up the login window.  When I look at the registry I see AutoAdminLogon set to 0 again.  Can someone help?

-------------------------------

Edit the registry.
In HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, add the following values:

AutoAdminLogon - must be 1
DefaultDomainName
DefaultPassword
DefaultUSerName
sopheakAsked:
Who is Participating?
 
FonnieConnect With a Mentor Commented:
 Sorry that this isn't working.  I got the registry info right from one of my servers that auto-logins every day.  I set this up using the AutoLogon program from the NT Resources kit.
  Looked at the sysinternals page for their AutoLogon program, (which may be the same one) and they state that if the password is (NULL), the logon will occur once and then will be disabled, which sound like what is happening to you.
  So, do you have a password for the account that you're using?  If not, set one, even it is 123456.
  Also, account that is valid to log in to the machine can be used in AutoLogon.  There is a DefaultDomainName key that has to be set.  We use a domain account every day.
  The easiest way to set this up is to log on with the account you want to use, and use the AutoLogon program to set the registry keys.
  This is SysInternals AutoLogon program.  http://www.sysinternals.com/misc.htm#AutoLogon

0
 
ValerieACommented:
Hi Sopheak, don't know if this is what your looking for but this is a registry hack from it-it-true.org:

On a dedicated special function server such as print server or application server, one might want to bypass the Logon dialog box and automatically logon to the server. Not recommended. If you want to set it on your standalone workstation at home, well thats a different matter.

Hive: HKEY_LOCAL_MACHINE
Key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Name: AutoAdminLogon
Type: REG_SZ
Value: 1 enable auto logon
Value: 0 disable auto logon
Hive: HKEY_LOCAL_MACHINE
Key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Name: DefaultUserName
Type: REG_SZ
Value: account to logon automatically
Hive: HKEY_LOCAL_MACHINE
Key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Name: DefaultPassword
Type: REG_SZ
Value: pw for DefaultUserName above
Caution: Password is stored in clear text. Set security permissions on Winlogon subkey to protect the account used.
Hive: HKEY_LOCAL_MACHINE
Key: SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Name: DefaultDomainName
Type: REG_SZ
Value: if domain account, domain name; if local account, server name

Also Sopheak, there is a free utility called Autologon that you can use instead of hacking the registry at
www.sysinternals.com/misc.htm
 
Whether you use the Autologon utility or the registry approach, there are times when you must logon as another user or need the logon dialog to appear. Hold down the shift key until during boot until the logon dialog appears.
Hope this helps.
0
 
apaduaCommented:
Try TweakUI. It's a tiny little control panel that does what you want, plus more.

Should solve your problems.

Cheers,

Andre
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
apaduaCommented:
Valerie,

Where's that site you mentioned, it-it-true.org?

I looked for it, since I didn't know it, and couldn't find it.

Thanks,


Andre
0
 
ValerieACommented:
To sopheak & apadua,  Sorry, there was a typo in my comments (my fault)to a web site that has hepled  me in the past. www.is-it-true.com
0
 
MacrosCommented:
The Autologon in TweakUI only works in Windows 9x not in NT
0
 
Tim HolmanCommented:
If you want to bypass the login screen, you need a new GINA DLL.
Look at :

http://wwwthep.physik.uni-mainz.de/%7Efrink/nt.html


It's not particularly wise to auto login the administrator account each time you start up !

Note that you can ONLY use the local Administrator account with the AutoLogon registry parameter.

0
 
sopheakAuthor Commented:
Thanks again
0
 
ValerieACommented:
Hi Sopheak,  I'm happy you got a solution to this particular problem. I'm just curious, since I'm new to this site, what was the solution? Editing the registry or using Autologon at the site I gave you? I'd really like to know (I may need to know this info in the future)  Val
0
 
sopheakAuthor Commented:
I used the registry,  THe solution was that I had to set a password to something other than null.  Sorry so late.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.