Forcing Win2K IRQ settings

Just installed Win2K - went in flawlessly.  Even recognized and installed my old POS Yamaha 192XG clone sound card.  Passed the U.T. acid test as well. <G>

One odd thing is it has put all of the following on IRQ 9:

ACPI IRQ
TNT2 video card
sound card
USB controller

I am somewhat concerned about a performance hit from this.
Unlike Win9X, it doesn't seem to want to let me manually assign IRQs to specific devices.

How can I force Win2K to let me assign whatever IRQ I want to a device? Device Manager refused me.
bios072698Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
LermitteCommented:
You do not have the option to disable IRQ steering in Device Manager on a
Windows 2000-based computer with Advanced Configuration and Power Interface
(ACPI) support installed.
 
CAUSE
=====
 
Fully compliant ACPI computers with ACPI support installed in Windows 2000 do
not require this option because of the nature of the ACPI specification.
 
RESOLUTION
==========
 
Contact your motherboard or PC manufacturer for an updated ACPI-compliant BIOS.
 
Mario
0
 
netmageCommented:
The question is, what happened to the rest of the IRQ allocation?

Of all the irq's to share, IRQ 9 would be the lowest performance as its part of a hardware legacy cascade set between irq 2/9.

In your PNP bios settings, make sure that you don't have "legacy ISA"tagged to anything unless you need this for a particular device.

Put the soundcard in a different slot.

Performance won't be a problem with the USB sharing an IRQ unless you have USB devices.

ACPI is still bug ridden with much hardware and win2k, so, if the rest of the hardware isn't PC99 compliant then its a waste of time having it activated.

When installing win2k, it seems to be a more reliable setting up hardware if the "PNP OS" setting in the bios is turned off.
0
 
bios072698Author Commented:
Thank you for your response.

I guess I'll leave it under ACPI for a while...it SEEMS to work ok, though it's a little slow waking up from sleep mode, probably due to my POS soundcard.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.