Solved

hasn't Button's Image at QReport Preview

Posted on 2000-04-17
7
198 Views
Last Modified: 2010-04-04
When I Preview a report, all button's image has missed,
do you know why?

thanks for your attention
0
Comment
Question by:kelvinyu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 7

Expert Comment

by:Motaz
ID: 2725592
Use ImageReport instead of buttons

Motaz
0
 
LVL 1

Expert Comment

by:bakry99
ID: 2725598
what about property of QuickReport?
   bakry
0
 

Author Comment

by:kelvinyu
ID: 2725734
I have run it at other PC. the image can be see,

about the Report Property, I only has set the Page and Page margin
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Expert Comment

by:bakry99
ID: 2725896
that's good.and mean that there is promblem on your PC or delphi Not nstalled well.
  try to delete it and Drope QuickReport again. and see the result.
 or try to use Delphi5 with service back
:-)
  bakry
 
0
 

Accepted Solution

by:
SuperSy earned 50 total points
ID: 2727648
This happened to me before, and that is because one Micorsoft dll file is missing/old.  It will run fine on one machine (usually has the latest Internet Explorer) while it doesn't on another one (that doesn't).

All you need to do is install the latest common controls dll from Microsoft, and the buttons come back.

The name of the installer is called "50comupd.exe", and you should be able to find it at Microsoft's site.  Try running it in the machine that does not work, and restart the machine.
0
 

Expert Comment

by:SuperSy
ID: 2727651
I think this is where you can get it.

<http://support.microsoft.com/support/kb/articles/Q186/1/76.ASP>
0
 

Author Comment

by:kelvinyu
ID: 2840427
SuperSy
I have install the 50comupd.exe , after that the probelm fix.

thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A lot of questions regard threads in Delphi.   One of the more specific questions is how to show progress of the thread.   Updating a progressbar from inside a thread is a mistake. A solution to this would be to send a synchronized message to the…
Introduction I have seen many questions in this Delphi topic area where queries in threads are needed or suggested. I know bumped into a similar need. This article will address some of the concepts when dealing with a multithreaded delphi database…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses
Course of the Month10 days, 17 hours left to enroll

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question