Driver By Driver

My computer started to run very slowly.  I also noticed that in the Properties page of the System notebook, I only had 16megs of RAM.  I know this to be wrong because I have 80megs.

I rebooted the computer and loaded the drivers one after another to find out what the faulty file was.  (Yes, I ran scandisk, defrag, virus checker..... first)  I found that when I opted not to load the config.sys file, everything went back to normal.  So, I then went into the config.sys to see if anything was unusual there, no there wasn't.  Just minimal stuff.  I rebooted as normal, again the problem appeared.  I then moved the config.sys file, nope.  I then renamed the Config.sys file, nope.  I then deleted the config.sys file, still nope.

Is this computer booting another config.sys that I don't know about?  How can I get my memory back?
Who is Participating?
1cellConnect With a Mentor Commented:
windows soesn't use the autoexec.bat or I should say doesn't require it.  However, many, many, current hardware and software components do utilize it and it can still cause problems.  Regardless, glad to point you in the right direction.

Troubleshooter for memory at:

Could it be autoexec.bat that you disabled at the same time?
when your computer starts booting up press F8, then a menu will pop up and one of the options is to pick which lines of the autoexec.bas/config.sys file you want to execute, This way you can try not loading different lines and find the problem line, and you will see the contents of the startup files that are being used. (This should answer your question about what config.sys is being used) once you find the problem line type REM in front of it, and see if everything works correctly.

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

You have a lot of troubleshooting tools under start-program files-accessories-system tools-system information.  Give these tools a shot in your troubleshooting.  You can also turn off pieces of your startup files and startup programs.
ryan3dAuthor Commented:
All comments look good.  But I have to leave now and will return to this problem tonight.
what nurnt out is talking about is the step by step confirmation from the 98 Start Up menu

now some comments of my own:

first, give us the text of the config.sys

2nd, from safe mode, go to start | run and type msconfig, then hit enter

under msconfig, check the box next to selective startup and remove the checkmark from process config.sys file

apply and restart normally

does it restart?

if so, you can now go back to msconfig and place the check back in process config.sys.   then, click on the config.sys tab at the top of the window and remove the check from the first line.  Apply and restart.  If it does restart, you found the problem.  If the system does not restart at this point, you will have to go back into safe mode, replace the check in the first line and remove from the second line.  Apply and restart.  Continue this process through the entire config.sys file until you find out which line is causing the problem.

then tell us
1cell, I never evan knew about msconfig.  pretty much the same thing i said but a lot easier.

(good to know for next time)

ryan3dAuthor Commented:
OK, again, all comments have been instructive.  Let me comment to 1cell.

From msconfig, I unchecked the config.sys checkbox and then rebooted.  Results: GOOD.

Here is the config.sys from msconfig
Also, it a match for the actual file.



There is a blank listing for autoexec.bat

Here is the result when I opened the file from an editor:



I'm going to try to recheck the config.sys box and then enable 1 line at a time.  Maybe I have good txt but bad binary.

do a find files on your computer for himem.sys and make sure it's in the c:\dos directory
ryan3dAuthor Commented:
I did and it is.  I also compared an old version and it also included a device=setver line, so I added that line.  I confirmed that it is in the windows directory. No effect.

jjcontact sugested that I go to the
website.  The site suggest:
 The real-mode CD-ROM driver from Teac for their 4x CD-ROM drive loading in the Autoexec.bat file has the parameter "xmssize= -1." This parameter can cause this behavior. The resolution is to change the parameter to "xmssize=0."

I have this CD-ROM.

But since my MSCONFIG is an empty page I wouldn't know what to add.  Again, the actual file exist but doesn't show any info in the MSCONFIG.

Do you think I should type in statements into the MSCONFIG for autoexec.bat?

Check Dosstart.bat - the next most logical place. I still don't get it why you have Autoexec.bat not in MSCONFIG. Something for me to work on.
If that doesn't do it do a FIND for files or folders containing the text xmssize= -1 on the C drive including all subfolders.
Do you think I should type in statements into the MSCONFIG for autoexec.bat?

No, you should edit the actual autoexec.bat

ryan3dAuthor Commented:
I fixed it.  I found a file (autoexec) that did not have a *.bat extension on it.  However, in the properties notebook, it was listed as a *.bat file.  This file was indeed empty.  So I copied and pasted the contents of the listed autoexec.bat file into this one and then rebooted.  It worked.

I applied some NT detective work to 98.  According to Peter Hipson book, Expert Guide To Windows NT 4 Registry,  windows doesn't really read the autoexec, config, winini or sysini directly from their files.  Insted, Windows refers to the registry and uses the values directly in the registry for these files or is directed to these files.  Well, some where along the line my copy of Windows started reading the empty file that wasn't listed as the autoexec.bat.

That explaination and some serious money will buy you an island in the tropics.  It works for now, as for later today, who knows.  
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.