• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 185
  • Last Modified:

Driver By Driver

SITUATION:
My computer started to run very slowly.  I also noticed that in the Properties page of the System notebook, I only had 16megs of RAM.  I know this to be wrong because I have 80megs.

WHAT I HAVE DONE SO FAR:
I rebooted the computer and loaded the drivers one after another to find out what the faulty file was.  (Yes, I ran scandisk, defrag, virus checker..... first)  I found that when I opted not to load the config.sys file, everything went back to normal.  So, I then went into the config.sys to see if anything was unusual there, no there wasn't.  Just minimal stuff.  I rebooted as normal, again the problem appeared.  I then moved the config.sys file, nope.  I then renamed the Config.sys file, nope.  I then deleted the config.sys file, still nope.

QUESTION:
Is this computer booting another config.sys that I don't know about?  How can I get my memory back?
0
ryan3d
Asked:
ryan3d
  • 4
  • 4
  • 2
  • +2
1 Solution
 
jjcontactCommented:

Troubleshooter for memory at:
http://support.microsoft.com/support/kb/articles/Q146/9/12.asp?LN=EN-US&SD=gn&FR=0

Could it be autoexec.bat that you disabled at the same time?
0
 
burntoutCommented:
when your computer starts booting up press F8, then a menu will pop up and one of the options is to pick which lines of the autoexec.bas/config.sys file you want to execute, This way you can try not loading different lines and find the problem line, and you will see the contents of the startup files that are being used. (This should answer your question about what config.sys is being used) once you find the problem line type REM in front of it, and see if everything works correctly.

Chris
0
 
slink9Commented:
You have a lot of troubleshooting tools under start-program files-accessories-system tools-system information.  Give these tools a shot in your troubleshooting.  You can also turn off pieces of your startup files and startup programs.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ryan3dAuthor Commented:
All comments look good.  But I have to leave now and will return to this problem tonight.
0
 
1cellCommented:
what nurnt out is talking about is the step by step confirmation from the 98 Start Up menu

now some comments of my own:

first, give us the text of the config.sys

2nd, from safe mode, go to start | run and type msconfig, then hit enter

under msconfig, check the box next to selective startup and remove the checkmark from process config.sys file

apply and restart normally

does it restart?

if so, you can now go back to msconfig and place the check back in process config.sys.   then, click on the config.sys tab at the top of the window and remove the check from the first line.  Apply and restart.  If it does restart, you found the problem.  If the system does not restart at this point, you will have to go back into safe mode, replace the check in the first line and remove from the second line.  Apply and restart.  Continue this process through the entire config.sys file until you find out which line is causing the problem.

then tell us
0
 
burntoutCommented:
1cell, I never evan knew about msconfig.  pretty much the same thing i said but a lot easier.

(good to know for next time)

chris
0
 
ryan3dAuthor Commented:
OK, again, all comments have been instructive.  Let me comment to 1cell.

From msconfig, I unchecked the config.sys checkbox and then rebooted.  Results: GOOD.

Here is the config.sys from msconfig
Also, it a match for the actual file.

DEVICE=C:\DOS\HIMEM.SYS
DOS=HIGH
FILES=30

STACKS=9,256
-----------------------------------------
FROM MSCONFIG:

There is a blank listing for autoexec.bat

HOWEVER:
Here is the result when I opened the file from an editor:

@ECHO OFF
PROMPT $p$g
PATH C:\WINDOWS;C:\DOS
SET TEMP=C:\DOS

Hmmmm

I'm going to try to recheck the config.sys box and then enable 1 line at a time.  Maybe I have good txt but bad binary.



0
 
1cellCommented:
do a find files on your computer for himem.sys and make sure it's in the c:\dos directory
0
 
ryan3dAuthor Commented:
I did and it is.  I also compared an old version and it also included a device=setver line, so I added that line.  I confirmed that it is in the windows directory. No effect.

jjcontact sugested that I go to the http://support.microsoft.com/support/kb/articles/Q146/9/12.asp?LN=EN-US&SD=gn&FR=0
website.  The site suggest:
 The real-mode CD-ROM driver from Teac for their 4x CD-ROM drive loading in the Autoexec.bat file has the parameter "xmssize= -1." This parameter can cause this behavior. The resolution is to change the parameter to "xmssize=0."

I have this CD-ROM.

But since my MSCONFIG is an empty page I wouldn't know what to add.  Again, the actual file exist but doesn't show any info in the MSCONFIG.

Do you think I should type in statements into the MSCONFIG for autoexec.bat?

0
 
jjcontactCommented:
Check Dosstart.bat - the next most logical place. I still don't get it why you have Autoexec.bat not in MSCONFIG. Something for me to work on.
If that doesn't do it do a FIND for files or folders containing the text xmssize= -1 on the C drive including all subfolders.
0
 
1cellCommented:
Do you think I should type in statements into the MSCONFIG for autoexec.bat?

No, you should edit the actual autoexec.bat

0
 
ryan3dAuthor Commented:
I fixed it.  I found a file (autoexec) that did not have a *.bat extension on it.  However, in the properties notebook, it was listed as a *.bat file.  This file was indeed empty.  So I copied and pasted the contents of the listed autoexec.bat file into this one and then rebooted.  It worked.

I applied some NT detective work to 98.  According to Peter Hipson book, Expert Guide To Windows NT 4 Registry,  windows doesn't really read the autoexec, config, winini or sysini directly from their files.  Insted, Windows refers to the registry and uses the values directly in the registry for these files or is directed to these files.  Well, some where along the line my copy of Windows started reading the empty file that wasn't listed as the autoexec.bat.

That explaination and some serious money will buy you an island in the tropics.  It works for now, as for later today, who knows.  
0
 
1cellCommented:
windows soesn't use the autoexec.bat or I should say doesn't require it.  However, many, many, current hardware and software components do utilize it and it can still cause problems.  Regardless, glad to point you in the right direction.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 4
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now