Solved

Why is Access Denied?

Posted on 2000-04-19
28
549 Views
Last Modified: 2013-12-29
This is a frustrating and bizarre problem.  Whenever I access the properties sheet of a file, it suddenly begins behaving as though it is a read only file.  No, the "read only" attribute does not become set--I've checked--but it becomes impossible to delete or change the file in any way untill I have restarted Win95.  Then whatever process has gotten hold of the file is terminated.  In the case of shortcuts to MS-DOS based programs, I am unable to change the properties to "close on exit" for example, becuase once I'm looking at the shortcut properties, the shortcut cannot be changed.  I DID figure out a work around for that which involved NOT opening up the pif file's properties, but opening it in the DOS Edit program and hacking it to my liking.  This method works, but its just plain crazy to have to resort to something like that.  If I start looking at file properties and then decide I want to uninstall a particular program, the uninstall will leave those files behind because access was denied to them.  This is happening whether I access the properties by pressing Alt+Enter or by using the right-click context menu.  Why is Win95 locking up my files like this?  This behavior even occurs in Safe Mode, so I'm pretty certain its something Windows and NOT another program is causing.  Unfortueatley, I don't know exactly when this glitch got into my system, so I can't pin it onto any particular program installation or any other system event.  What could be causing this and how do I fix it?
0
Comment
Question by:knat
  • 14
  • 5
  • 5
  • +4
28 Comments
 
LVL 1

Expert Comment

by:Ted22
ID: 2732765
Only guess I can make is a virus.
0
 
LVL 1

Expert Comment

by:deltree
ID: 2732801
I've seen wierd problems like this fixed by booting to safe mode for a scandisk. Not sure why, but is works once in a while, and it's easy to try.
0
 

Author Comment

by:knat
ID: 2732861
I updated my anti-virus program's virus pattern file and am doing a full scan right now to see if anything shows up, Ted22.  I'll try the safe mode scandisk, too, deltree.  Meanwhile I'm still open to any and all suggestions.
Thanks!
0
 
LVL 63

Accepted Solution

by:
SysExpert earned 250 total points
ID: 2734811
Sometimes the anti-virus program is the CAUSE of the error. try disabling it and see if it still happens.
Also
Download the Startup COP a free pcmag utility from
                       http://www.zdnet.com/pcmag/pctech/content/18/08/ut1808.001.html

 Run it and it will show you everything that is listed in all the possible startup
places, and allow you to disable things one at a time until the problem is eliminated.

I hope this helps.
0
 
LVL 6

Expert Comment

by:1cell
ID: 2735126
I think sysexpert is on the right track.  It sounds like there is something running here which is stopping you rfrom getting access to anything.  Virus software, trojan protection, anything with the word Norton on it, could cause things like this.  

Check while you are in safe mode if the problem persists.
0
 

Author Comment

by:knat
ID: 2736264
I used to run a lot of  background programs, virus scanner, email notifier, clip utility, etc. and had a pretty full system tray, but now I keep things pretty clean and only start those things when I actually need them.  As a result, my system crashes mush less frequently.

I'll give startup Cop a try to see if I'm missing anything.  Maybe even Win Top would show me something, but it seems to me I tried that before.  I used to have a program that was much more advanced than WinTop that showed EVERYTHING that was being accessed.  I don't know if I still have that and can't remember what it was called.  I agree there has to be some process going on.  How it latches onto specific files and locks them up is a still a mystery.  

BTW, I use Intel LanDesk as my virus scanner and a scan came up clean yesterday. I don't run it at startup, only manually.  I DO have some Norton stuff, but never installed thier antivirus.  I knocked the Norton programs out of the startup folder and out of the Run sections of the Registry.  Still, I've got the Norton Protected Recycle Bin if that means anything.

While I'm at it I might as well mention another glitch that MIGHT be related to this problem:  Some of the items in the right-click context menu for files in Explorer are missing.  "Open" was even missing for a while untill I ran Norton System Doctor.  "Print" is still missing.  So are some I manually created for html files such as "Open in Netscape".   Strangely enough, all of these items are present when I view files within a zip file(or folder as it appears) in ZipMagic.(I've tried disabling ZM as well--that doesn't change anything either)

I don't know if I've confused the issue or shed some light.  I'm at another computer now at won't be back at my problem plagued pal untill Fri or Sat.
Thanks for the ideas.
Ken
0
 

Author Comment

by:knat
ID: 2741313
Adjusted points from 150 to 250
0
 

Author Comment

by:knat
ID: 2741314
So far I've tried everyone's suggestions to no avail.  My problem persists after scanning for a virus as Ted22 suggested, running scandisk in safe mode(deltree's idea), and turning off all of my startup progs with Startup COP as SysExpert advised.

After those ideas failed I ran WinMag Task List and saw processes listed that don't show up on the Windows Ctrl+Alt+Del task list.  It lists "windows" with handle and title, like this:
496: <no title>
2024: OutlookExpressHidden Window
2904: OleMainThreadWndName

and so on.  With just a half dozen background programs listed on Window's Close Program window, 53 "windows" were listed in WinMag Task List.  When I opened a file properties window, that number went up to 56.  When I closed the properties sheet, it went down to 54.  Repeating this several times for various files, I saw the number go up by 3 each time, but the lower number stoppped rising after reaching 55.  Now with Outlook Express and IE5 open, it shows 110 "windows" and goes up to 113 when I open a file properties window and back down to 110 when I close it.

Still, for each file whose properties I check I will get the folling:

"Error Deleting File" (window title)
"Cannot delete <filename>: Access is denied"

"Make sure the disk is not full or write-protected and that the file is not currently in use."

My hard drive in neither full nor write-protected so I am led to believe that the file(s) must somehow be in use.

The question is: "BY WHAT????"  And how the heck do I turn off this mysterious phantom that's driving me crazy???

Apparently this question has a high level of difficulty so I am going to up the ante and add 100 points to its value, because I REALLY want a solution!

It may be a week before I can work on this computer again, but meanwhile, PLEASE OFFER YOUR SUGGESTIONS.  Thanks in advance, and Happy Easter!
--Knat
0
 
LVL 10

Expert Comment

by:emery800
ID: 2742631
It still may be a virus! What anti-virus software are you running? If its MaCaFee (spelling!) try another. This in my opinion rates a minus two on a scale of 1 to 10, 10 being great! Dave
0
 

Author Comment

by:knat
ID: 2745755
No Dave, its not McAfee (correct spelling i think).  It's Intel LanDesk.  What av scanner would you recommend?
--Knat  °°
0
 
LVL 10

Expert Comment

by:emery800
ID: 2745811
I have not done a lot of research on who thinks what is the best. The firm I work for uses Inoculan which supports 95/98 and NT. Its fair and is easy to use and appears to be effective, its also easy to schedule it to update the servers and workstations. I use command systems software (FPROT) on my machines. It also is easy to use and update. Using both of these it has cured all known viruses that have hit, but like anything else you have to stay on top of the situation and monitor everything closely. Are they the best, got me! I know a lot of people swear by Norton's, don't use it I use to but their programs are memory hogs and are very powerful. I ended up ruining two harddrives with Norton's utility. So they only Norton product I use now is winfax9.0, its a memory hog but program works great. We use Rightfax but it is only available when connected to server, so I use the two of them together. I have had about a dozen people either approach me or I overhead them talking about a virus. When I investigated they were all using McaFee and had updated to latest definitions. I installed FPROT and came up with about 300 files on one machine I remember with I can't remember how many viruses. McAFee couldn't find one of them. So I am not saying it is a bad product, however, it has not shown me anything I like, bottom line its user preference. The other thing I dislike about Mcafee is that I purchased a new cmpact laptop and I have worked on other machines (Compact) and Mcafee comes preinstalled, guess what no uninstall, I have spent a couple of hours clearing it all from sys files and registry. That is rediculous to not have the option to add/remove or any install, its implanted that deep! Why? Oh well you did it, you got me to rant and rave! Ha Ha! Take care Dave
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 2747681
PCmag just gave McAfee and Norton the thumbs up. So try either of them.
Make sure you run it from the CD, ( no install ) or from a known clean boot floppy.
I hope this helps.

0
 
LVL 10

Expert Comment

by:emery800
ID: 2748183
As I indicated above its a user preference! I do not mean to bad mouth any product! If it works for you then have at it. However, recognize just because its written is not proof that its good, I am sure politics are around (always is when money is involved) and we just have to be open minded! Later Dave
0
 

Author Comment

by:knat
ID: 2748798
Well, I have a copy of Norton's on a CD which is only about a year old, so if I run it from the disk the definitions may be a bit out of date.  Maybe that will turn up something.  I was using the latest definitions with LanDesk which turned up nothing.

I'm not 100% convinced that this is a virus, but I will try a few other scanners when I get back to my machine.  Thanks for your continuing efforts, guys!
--Knat
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 5

Expert Comment

by:johnsavior
ID: 2758766
Hi knat,

I think this problem not caused by virus or trojan.
I believe there is corruption on your Registry System especially on file properties shell command item.
This problem might be happened because there is conflict interest inter program application that you has been installed.
I give you suggestion to reinstall your Windows, but before you reinstall try to delete file C:\SYSTEM.1ST

Good luck
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 2759994
For cleaning the registry, here are some tips from smeebud:
I hope this helps !
---------------------------
Registry keeps deleted data too. It acts simmilar like MSDOS undelete. The data      remains in registry but it is not visible to you. So we use regedit to export    only visible   data and than rebuild registry from that data. (it helps us get rid of unwanted    data).
   Here's the procedure:

 1. Make backup copies of system.dat (and system.da0) and user.dat
 (user.da0). Be   carefull, if you use multiple user profiles than your user.dat is located in                        \WINDOWS\Profiles\user_name\USER.DAT, system dat is always in
                       \windows.
 If you have multiple user profiles than backup both \windows user.dat
   (user.da0) and    \windows\profiles\user_name\user.dat user.da0)

  2. Do you have MS regclean? If not than download it from Microsoft. This is    very     important!!
Regclean cleans registry from all the trash, dead links etc. so  regedit can
  export it normally. I was not able to export registry untill I cleaned it with  regclean! Run    regclean and have it clean all the errors it can find. If you want to undo the      actions
 regclean did in registry just doubleclick on result file regclean makes (looks      like:         COMPUTER_NAME XX XX XX (date).reg) That will import all the changes    back to the     registry.

 3. Restart computer. When starting (when displays "starting Windows95"      message)
 press F8 and select "safe mode command prompt only" (should be the last       item in the  list)

  4. Go to \windows and enter: (I'll take for example that you have windows    installed in C  drive in directory Windows) In case you don't have multiple user profiles:
 regedit /L:c:\windows\system.dat /R:c:\windows\user.dat /E myreg.reg

   In case you have multiple user profiles: (change "user_name" with your user     name, name
  of directory under \windows\profiles where your user data are stored ex. ifyour user  name is John it will look like \windows\profiles\john\

  regedit /L:c:\windows\system.dat  /R:c:\windows\profiles\user_name\user.dat     /E myreg.reg

 Wait for regedit to return to command prompt. If it doesn't return to the
  command prompt,      than something must be wrong!

    5. Type (in c:\windows): attrib -s -h -r system.dat attrib -s -h -r system.da0         attrib -s -h -r
  user.dat (if use multiple user profiles do this in your user directory:
    \windows\profiles\user_name\) attrib -s -h -r user.da0 (if use multiple user     profiles do this     in your user directory \windows\profiles\user_name\)

   Now DELETE system.dat, system.da0 (in \windows) user.dat and user.da0    (OR from       \windows\profiles\user_name IF you use multiple user profiles, if that's the  case, LEAVE
  those in \windows directory. DO NOT DELETE THEM, delete only those from     your user directory. If you do not have multiple user profiles, than you need to delete   the ones from   \windows directory)

   6. Enter (in \windows directory)
  regedit /L:c:\windows\system.dat /R:c:\windows\user.dat /C myreg.reg

7. Reboot your computer (DO NOT START WINDOWS WITH "WIN"!!)

 8. If any kind of error happens, you can copy system.dat & user.dat files you have   backuped before, back to \windows directory.

  9. Now you can compare sizes of old system.dat & user.dat and new ones    (to view them   in explorer you have to turn on "show all files" option in Windows explorer  view menu)
                                                         
                                 METHOD 2

 Here is a safe technique that can reduce the size of the Registry up to 10
 percent. Make  a backup of your system and especially the current Registry. Under Windows 95, use     the ERU program located on the Windows 95 CD. Under Windows 98, run  ScanReg by                   entering SCANREGW.EXE in the Start/Run menu. In Windows 95/98, open the Registry  Editor and export the current Registry to a REG file, such as    C:\MYREG.REG, by       selecting the Registry/Export Registry File command with the All button  highlighted.
                       Restart Windows in an MS-DOS Mode sessi on. Or reboot, press Ctrl at boot  time and  select Command Prompt from the Windows 98 Startup menu. Enter  SMARTDRV at the
 C: prompt to load the DOS disk cache. After the successful creation of the MYREG.REG export file, run RegEdit once more from C: as follows:
                       REGEDIT /C
                       MYREG.REG

  This will recreate a new compact version of the Registry in the \WINDOWS   directory.

                       Regards,
                       Bud
                       http://www.geocities.com/budallen98_98/
                       Bud's Win95 Win98 Tips and Troubleshooter

------------------------------------
From: smeebud        Date: Sunday, March 26 2000 - 05:50PM EST

                       This should clean it up without all the hassle.

                       Win95/98 Registry Rebuild

                       Rebuild the registry itself with REGEDIT. To do this, restart the computer
                       in MS-DOS mode-REGEDIT will do only what you need it to in DOS mode         while                 the registry is closed.

                       1) Export the current registry into a text file by running the following            from within the Windows directory: REGEDIT /L:SYSTEM.DAT    /R:USER.DAT /E        FULLBAK.REG
This will force REGEDIT to parse the registry and dump its
   raw      contents to the text file FULLBAK.REG.
 2) Make a backup directory and move your USER.DAT and SYSTEM.DAT
    into that           directory so REGEDIT cannot find them. (This step is just a precation. I've   never seen a situation where this trick doesn't work, but there's alway a   first, and now you'll have a backup.)

  3) Recreate the registry and running the command: REGEDIT
     /L:SYSTEM.DAT  /R:USER.DAT /C FULLBAK.REG

  4) Reboot and voila! A registry free of corruption (but not necessarily
                       free of dead wood).

  You can also in Win95 export the entire registry and later double click it
                       to install it. But this only works on an already running machine.

                       If you are doing this on a network, you can use your NT Server to backup
                       the registry via NET USE, then AT (time) REGEDIT /L:SYSTEM.DAT       /R:USER.DAT        /E FULLBAK.REG
 copy fullbak.reg to your backup area and copy it to tape or CD.
0
 

Author Comment

by:knat
ID: 2767239
I'm going to try cleaning the Registry using smeebud's method first. Anything to avoid reinstalling Win95 from the CD!  I'll be back shortly.--knat
0
 

Author Comment

by:knat
ID: 2768408
Yuchhh!  I was in DOS. After typing:
REGEDIT /L:USER.DAT /R:USER.DAT FULLBAK.REG
got the following message:
"unable to open registry (14) - SYSTEM.DAT"

So much for that fix.  So I got back into the Win95 gui and cleaned up the Registry a bit with Norton System Doctor and then ran Norton Registry editor and exported the whole registry to a textual .reg file.

That's as far as I've gotten today.  I can either use the Norton Regedit to import the whole Registry from this file or I thought I might try restoring the Registry from it in DOS using:
REGEDIT /L:SYSTEM.DAT /R:USER.DAT /C (nortonbackup).reg

Of course I've got backups of my Registry.

I'll keep you posted on my progress.  I may ask for some tips before reinstalling Win95 if I have to bite that nasty bullet

Meanwhile, thank you all for your continuing help!!!
--knat
0
 

Author Comment

by:knat
ID: 2772411
Still trying to make get my possibly corrupted Registry fixed before going the reinstall Win95 route.  I named the Registry backup created by Norton's Regedit program, "FULLBAK.REG".

Then, in DOS I ran:
REGEDIT /L:SYSTEM.DAT /R:USER.DAT /C FULLBAK.REG

Well, it looked like it was going to work.  For over two hours my computer thrashed and cranked while the %age completed gradually inched upwards.  Finally, it finished, but then started spitting out error messages:

Cannot access Registry
The previous Registry has been restored
Cannot open Command.com
Memory access violation
System halted

So I rebooted and am still right back where I started.

I don't know if this happened because my Registry is so big (user.dat=1232 kb and system.dat=4167 kb) or if it was a Norton thing.  I'm still going to se if Norton's Regedit can do the restore and see where it goes from there.

I also discovered a couple of old Registry backups on my system in the process of searching for user.* and system.* .  One hopelessly old, but another was only one year old, which I tried to use.  Unfortuneately It predated IE5, so that's probably why I kept getting "EXPORER.EXE HAS CAUSED A PAGE FAULT IN EXPLORER.EXE." Due to this, I was unable to even get beyond my Windows logon password, so I had to restore my current Registry again.

BTW, I've cleaned up my Registry with Norton WinDoctor and it is NOT telling me that there is any corruption.

I still haven't tried everything that's been suggested here, so I'm withholding judgement on johnsavior's answer until then.

Verbosely yours --knat
0
 

Author Comment

by:knat
ID: 2791917
I am about ready to accept johnsavior's asessment that I need to reinstall Win95. but I am going to reopen the question for more input before doing so.

I tried running RegClean 4.1a, but it stops responding while scanning Class Identifier Libraries for errors.  Several times, always at the same point, and even in Safe Mode.  So maybe thats where my probliem is? Or maybe its just a RegClean failure, too.

Anyway, if I reinstall, I'll do it the quicker(?) way first without reformatting, because I want to save my software and I do not have access to a zip or cdrw drive to back everything up on.

I may also decide to just live with this problem for a while longer, as the hassle and pain of reinstalling Windows may exceed that caused by this (and a few other) irritating glitches.

I'm not 100% satisfied with jophnsavior's reinstall answer, because I'd prefer a more surgical strike and I'd really like to know just exactly what caused this problem.  I also realize that may be too much to ask for.

One other thing I will do in an attempt to cure this problem myself is to uninstall a few of the programs I've installed during the past 6 months to see if one of them might be at the root of this.

Ken
0
 
LVL 10

Expert Comment

by:emery800
ID: 2792545
If it comes down to you doing a clean reinstall, you might try removing all that is ALL Norton Programs and then on reboot see what happens. I use to use the Norton Programs, however, they are powerful and memory Hogs. If you remove all traces to Norton it would be interesting to see if you still have the problem. Best of Luck, hate to concur on doing clean install, however, I usually do a clean reinstall every couple of months because I do so much experimenting with the OS's. Not worth the time to find all the little problems. Dave
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 2793153
Second method to clean up registry :

 Here is a safe technique that can reduce the size of the Registry up to 10
 percent. Make  a backup of your system and especially the current Registry. Under Windows 95, use     the ERU program located on the Windows 95 CD. Under Windows 98, run  ScanReg by                   entering SCANREGW.EXE in the Start/Run menu. In Windows 95/98, open the Registry  Editor and export the current Registry to a REG file, such as    C:\MYREG.REG, by       selecting the Registry/Export Registry File command with the All button  highlighted.
                       Restart Windows in an MS-DOS Mode sessi on. Or reboot, press Ctrl at boot  time and  select Command Prompt from the Windows 98 Startup menu. Enter  SMARTDRV at the
 C: prompt to load the DOS disk cache. After the successful creation of the MYREG.REG export file, run RegEdit once more from C: as follows:
                       REGEDIT /C
                       MYREG.REG

  This will recreate a new compact version of the Registry in the \WINDOWS   directory.
----------------
0
 

Author Comment

by:knat
ID: 2799256
YES!  Finally have fixed the problem!!!

Johnsavior was on the right track in saying that there was a conflict with another program I had installed, however it was NOT necessary to reinstall Win95 as he suggested.  All I had to do was uninstall ZipMagic 2000 and everything returned to normal.  No more access denied messages after viewing file properties.  The right-click menus which had been incomplete, except with files viewed within zip "folders", also returned to normal.

I am very happy to have figured this one out without having to reinstall Windows!  I've gone back to using WinZip7.  Now I suppose I'll have to withdraw this question since the system here doesn't give me any points for figuring out my own problem, but before I do I thought all of you who helped me tackle this would be interested in knowing the problem's resolution.

Too bad the solution here will be lost in cyber-bits when the question is withdrawn, but perhaps we'll be able to help anyone else who may be using ZipMagic.  Guess I'll check the ZM website and see if there is a workaround so ZM can be run without this system bug ocurring.

Thanks again to all of you!
Ken :)          ==°°==
0
 

Author Comment

by:knat
ID: 2800608
On second thought, I'm going to accept SysExpert's first comment about checking for anything that could have been running, as it did help get me thinking along the right line, although apparently the problem was not so much the "running" of any software, but rather systemic changes caused by the software (ZipMagic) that was installed on my system preventing access.  The problem persisted even when ZM was disabled and only cleared up when it had been uninstalled.

ZipMagic enables the system to view zip files as folders which can be viewed from within Explorer and allows other programs to save to files that are located in zip files.

Too bad there's not a way to spread the points among several experts as all of you were helpfull.  Thanks again.
Ken
0
 

Author Comment

by:knat
ID: 2800637
Thanks, SysExpert, for helping get me on the right track even though the specific actions you suggested didn't quite get to the heart of the problem here.  Ken
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 2801123
I'm glad I could help. I can't always pinpoint an unusual problem, but I can usually point you in the right direction, and get you thinking. I'm glad things are working now.

0
 

Author Comment

by:knat
ID: 2806422
Final wrap up--

Knowing that the problem was caused by ZipMagic, I went to the program's website.  My problem was listed as one of the bugs that could be cleared up with an available update, so I've reinstalled it along with the updates and now I can view my file's properties with no subsequent access denied problems.

Sometimes the solution isn't to reinstall Windows! Ha!

Ken
0
 
LVL 10

Expert Comment

by:emery800
ID: 2806876
That is great that you fixed without having to reinstall! There are a lot of great people in this forum and teamwork usually will bring out the right fix required. Each case is not usually the same and requires a good evaluation of the comments which you did to fix this problem! Good Luck, regards, Dave
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now