Solved

OS2 protocols/parameters for NT network

Posted on 2000-04-19
8
472 Views
Last Modified: 2013-12-27
This is my first time dealing with OS/2 and no one at my company is familiar with it (an external customer uses OS/2, so I must also).  I need to get the OS/2 machine talking to our NT network.  Using NetBios, and TCP/IP in the OS/2 machine, I can get the networking components to start up (without error), but the OS/2  and NT are not seeing one another (can't ping each other, or use net view).  If I use NetBios over TCP/IP I get errors as OS/2 boots, and the networking components are aborted.  What am I missing?  
0
Comment
Question by:jcd2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 12

Expert Comment

by:Otta
ID: 2733752
You need to configure NT and OS/2 to use the same protocol, either NetBIOS or TCP/IP, so that they have a common "language" with which to communicate.

PING requires TCP/IP on both computers.

What protocols are installed on each system?

Use the 'NETSTAT' command on each machine, to check routing parameters.

What error-messages do you get when trying to use NetBIOS over TCP/IP ?
0
 

Author Comment

by:jcd2
ID: 2735289
Thank you, Otta, for your comment.

My NT machine, which in on the NT network, uses TCP/IP and NWlink NetBIOS plus NWlink IPX (a netware related protocol?)

The OS/2 has TCP/IP and I have tried NetBios in three ways, always combined with the TCP/IP (NetBios, NetBios over TCP/IP, and all the protocols needed for Netware (IPX, netware requester, and aform of NetBios))

During load messages on OS/2 look like (using NetBios over TCP/IP or a netware related NetBios, to be more similar to the NWLink NetBios):

TCPBeui: Using a 32-bit data segment.
Net3403: The NET1 NETWORKS entry in the IBMLAN.INI file has a syntax error and will be ignored.
SYS1719: The file C:\IBMLAN\NETPROG\NETWKSTA.200 specified in the IFS statement on line 119 of the config.sys file does not contain a valid device driver or file system driver.  Line 119 is ignored.

At the end of the boot, the following error occurs:
LNM0038: Either Network Messaging or the Netpopup service is already running.  Network Messaging cannot be run if either of these are already running.

The NET1 NETWORKS is garbage (tc***g***g*5,0,LM10,100,100,14 - * are various strange characters)

The referenced file nwtwksta.200 exists in the proper directory.

I have run netstat on both machines, but the output is so different its hard to know what to compare.

0
 
LVL 12

Expert Comment

by:Otta
ID: 2736237
> does not contain a valid device driver or file system driver.

I'd be tempted to use MPTS, on the OS/2 machine, to remove all the network components, shutdown, reboot, and then install NetBIOS over TCP/IP.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:jcd2
ID: 2736374
Thank you again Otta,

You may have hit on something.  I did as you suggested and got improved results - the error in the IBMLAN.INI file went away - the entry became NETBEUI$,0,LM10,100,150,14 (which is now sensable), but the error:
SYS1719: The file C:\IBMLAN\NETPROG\NETWKSTA.200
still remains, as if the file NETWKSTA.200 is either corrupted, or altogether the wrong file (but it does exist).  Perhaps I need to see if IBM has another version of this file available for download?
0
 
LVL 8

Expert Comment

by:ViRoy
ID: 2740118
im not 100% sure but i do believe your gonna have to install gateway services for netware on the NT box.
0
 

Author Comment

by:jcd2
ID: 2745550
My problem seems to have been narrowed down to a specific driver: the file system driver netwksta.200, and it appears to be part of the file and print client setup.  The driver exists, but at boot up I get the error SYS1719: "...not a valid ... file system driver" in the IFS (installable file system) command in config.sys.  This error occurs when trying to load the NetBios over tcp/ip protocol.  Is there an updated (or alternative) driver available somewhere? Or any other experience with this type of error?
0
 
LVL 12

Accepted Solution

by:
Otta earned 50 total points
ID: 2746167
Check IBM's web-site:
http://WWW.RedBooks.IBM.Com/abstracts/sg242009.html
"Network Clients for OS/2 Warp Server: OS/2 Warp4, DOS/Windows, Windows 95/NT, and Apple Macintosh, SG24-2009-00".

Click on "view this RedBook".
------

 This redbook details OS/2 Warp Server enhancements and emphasizes the integration of
 Windows 95 and Windows NT Workstation clients in an OS/2 Warp Server environment. We
 illustrate how to install and configure OS/2 Warp Server clients such as: o OS/2 Warp 4 o
 DOS LAN Services for DOS and Windows o IBM Networks Coordinated Logon Client for
 Windows NT 4.0 o IBM Networks Primary Logon Client for Windows NT 4.0 o Apple
 Macintosh

 Each platform discussed focuses on file and print services configured for NetBIOS and
 TCP/IP environments, dynamic TCP/IP, where appropriate, and remote access through the
 Point-to-Point Protocol (PPP). The information in this redbook is intended to help network
 administrators in enabling various clients, such as OS/2 Warp 4, DOS (with or without
 Windows), Windows 95, Windows NT, and Apple Macintosh, to work with OS/2 Warp Server
 4.0. The enhancements made to OS/2 Warp Server since its roll-out in October 1995 are
 included. This book also provides end users with the knowledge they need in order to work
 more efficiently with their clients in a networked environment.
0
 

Author Comment

by:jcd2
ID: 2752970
Thank you again Otta.

The redbook was helpfull.  For now I have scaled back my ambitions and have gotten tcp/ip functioning, such that I can use ftp software and browsers to communicate.  The ultimate problem (wrt to tcp/ip) was the NIC configuration, and that has now been solved.  The redbook will likely help get lan services configured, should they become necessary.  Thank you for your help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Occasionally Windows/Microsoft Updates will fail to update. We have found a code that will delete all temporary files and re-register all dll's related to Windows/Microsoft Updates! This works 99% of the time to get the updates working again! The…
I don't know if many of you have made the great mistake of using the Cisco Thin Client model with the management software VXC. If you have then you are probably more then familiar with the incredibly clunky interface, the numerous work arounds, and …
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question