Solved

Dial Up Server

Posted on 2000-04-19
4
309 Views
Last Modified: 2013-12-15
how do i setup a dial up server in RedHat 6.1
0
Comment
Question by:coolbeans_22
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 12

Expert Comment

by:j2
ID: 2734313
to do what? strictly shell? ppp? slip? and also what do you want it to do? route? masquerade? nat?
0
 

Author Comment

by:coolbeans_22
ID: 2736723
ppp
i want to be able to dial into my linux computer and use my cable modem instead of paying more money to my ISP  
0
 

Accepted Solution

by:
shelby38 earned 125 total points
ID: 2738674
I use a linux (Mandrake 7.0) as a up server. I’ll assume you have a network setup and working.

First I create a file called
rc.firewall

/sbin/depmod -a
echo -n "Starting Firewall Script"

echo "1" >/proc/sys/net/ipv4/ip_dynaddr

ipchains -M -S 7200 10 60

/sbin/modprode ip_masq_ftp
/sbin/modprode ip_masq_raudio
/sbin/modprode ip_masq_irc

ipchains -P forward DENY

ipchains -A forward -s 10.8.11.0/24 -j MASQ

I saved this in my rc.d directory

Then edit /etc/ppp/options file

demand
idle 1800
ipcp-accept-remote
ipcp-accept-local
lock
noauth
defaultroute
user “Your User Name”
remotename “Your ISP”
/dev/modem 115200 crtscts
connect '/usr/sbin/chat -v -f /etc/sysconfig/network-scripts/chat-ppp0'




then edit /etc/sysconfig/network-scripts chat-ppp0

'ABORT' 'BUSY'
'ABORT' 'ERROR'
'ABORT' 'NO CARRIER'
'ABORT' 'NO DIALTONE'
'ABORT' 'Invalid Login'
'ABORT' 'Login incorrect'
'' 'ATZ'
'OK' 'ATDTyourispphone#
'CONNECT' ''
'ogin:' 'your login'
'ord:' 'your password'

next edit /etc/sysconfig/network-scripts/ifcfg-ppp0
PERSIST=yes
DEFROUTE=yes
ONBOOT=no
INITSTRING=ATZ
MODEMPORT=/dev/modem
LINESPEED=115200
ESCAPECHARS=no
DEFABORT=yes
HARDFLOWCTL=yes
DEVICE=ppp0
PPPOPTIONS=
DEBUG=no
PAPNAME=
REMIP=
IPADDR=
BOOTPROTO=none
MTU=
MRU=
DISCONNECTTIMEOUT=
RETRYTIMEOUT=
USERCTL=no

Now add these two line to the end of  your /etc/rc.d/rc.local file

/etc/rc.d/rc.firewall
/usr/sbin/pppd :10.0.0.2

reboot and your system should dial on damand.





0
 

Author Comment

by:coolbeans_22
ID: 2739158
i use redhat 6.1 is that going to be a problem
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question