Solved

Question about DHCP and my NIC config.

Posted on 2000-04-20
2
169 Views
Last Modified: 2010-03-18
I'll try to keep this short.

I've installed Mandrake 7.0 for the very first time, so I guess you can say I'm a total nitwit with Linux.
I spend my days with reading howto's and stuff, there is just one problem:

I have to do it in Windows. Well, not really a problem, but it's stupid to switch every time i want to look something up on the internet to switch back to Windows.

Well, I guess you say: Why don't you use Linux for it. Taadaa! The problem!

Okay, I'll try to explain what the problem is. I've installed Mandrake and my NIC is luckely detected (yay). When I use the console and use the ifconfig eth0 command it does show all the details. Now, I have an cable internet connection, which requires DHCP support for I have a dynamic IP.

Therefor I've installed dhcpcd. When I take a look at dhcpcd.info it does show, everything. My IP, Subnet, DHCP server IP, etc etc.

The strange thing is when I try to configure my NIC with netconf, it won't load on the next boot of Kernel. It fails saying: bringing up eth0 Delaying eth0 configuration.

After that doesn't show any details with ifconfig anymore and it's kinda useless. When I clean all the fields in netconf and apply that it still gives me the 'error' during booting the kernel and still I can't go online.

Does anybody have suggestion or can offer me any help???

I would be so gratefull!!!

Greetz,

Olli
0
Comment
Question by:Olli
2 Comments
 
LVL 12

Expert Comment

by:j2
ID: 2737773
Uhm, just set the card to "dhcp" in whatever config program you use, Mandrake 7 is delivered with a dhcp client.

If it really says "Delaying ethX initialization" that means (in most cases) that you have a hardware conflict.
0
 

Accepted Solution

by:
tomwj earned 50 total points
ID: 2864774
In Mandrake use the DrakeConf or linuxconf program that installs with it, choose the Network Configurator, and click on the Basic Host information.   Choose the tab for the appropriate adaptor (usually adaptor one, eth0).  Check enabled, and dhcp.  Choose the driver to use at the bottom, and enter the io address and irq to use if you know them.  That should set it, this has worked on all madrake boxes for me.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

27 Experts available now in Live!

Get 1:1 Help Now