Install USRobotics External Sportster Faxmodem on NT 4

Basics:
PC running Windows NT 4.0 Service pack 5
Intel 333Mhz Celeron processor
256 Megs of Memory

2 com ports:
com2 has a mouse on it
com1 is where I'm attempting to install the modem

USRobotics 56k Sportster Faxmodem with x2 External

What I've tried so far to get the os and modem working together:

1. Install in a normal manner (control panel, modems, general tab, add, and go through the wizard) NT could not detect my modem so I installed it by selecting from the list and installing the driver that is shipped with Windows NT 4 (3Com Corp. U.S. Robotics 56K FAX EXT).  I also tried a driver downloaded from 3Com's web site but it was no better.  Rebooted.

2. Went to control panel, ports, and removed all ports.  Rebooted.  Com1 was added back (I did not expect com2, where the mouse is located, to appear.)  NT would not detect the modem and would not dial out when the modem was manually setup.

3. Changed the port settings to 3f8 base i/o and irq 4. Rebooted. NT still would not detect the modem and would not dial out when the modem was manually setup.

4. Went to control panel, Devices. Scrolled down to Serial, clicked Startup and changed it from Automatic to System. Rebooted. NT would not detect the modem and would not dial out when the modem was manually setup.

5. Replaced the data cable to the modem with one that I'm sure works.  NT would not detect the modem and would not dial out when the modem was manually setup.  Info: A phone is hooked up to the phone jack on the modem and I get a dial tone (on the phone).

6. Went into system BIOS setup.  Changed IRQ 4 used by ISA to yes (was No/ICU).  Still no luck detecting or dialing.

7. Used Internet Explorer's - Tools, Internet Options, Connections tab, Setup wizard.  No better luck.

Finally some more info -

The modem was working on a Linux machine before I got it so I'm sure the modem itself works.

Yes, I am logged in as Administrator.

Thank you for any help you can provide.

rjacobsn
rjacobsnAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
OttaConnect With a Mentor Commented:
> I tried swapping the modem and the mouse.

The fact that the mouse continues to work shows that both the COM1 and COM2 ports on the motherboard are working correctly, and that both ribbon-cables from the motherboard-ports to the back-plane connectors work correctly.

> 5. Replaced the data cable to the modem with one that I'm sure works.

So, if the hardware "inside" the computer is not the problem, and the data-cable(s) are not the problem, then what's left -- only the modem itself.

Retry the modem on the Linux system.
Just try 'ECHO ATDT111111111 > com2',
and listen/watch the modem, to see if it goes "off-hook" and if you can hear it dial '11111111111'.
0
 
rayt333Commented:
Check the dip switches and see which are down, should be 3,5,&8 down
0
 
rayt333Commented:
Also you may want to check in the CMOS setup to make sure the serial port itself is not disabled
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
rjacobsnAuthor Commented:
Thanks rayt333.

I checked the dip switches and they are as you said... 3,5&8 are down the rest are up.

I checked the CMOS for the serial port being disabled... it isn't.  Com1 is set to 3f8 irq 4.

I had another thought, I'll try swapping the mouse and modem on the serial ports next (so mouse is on Com1 and modem is on Com2).  We'll see if it's the com port or some other problem.

rjacobsn

0
 
rjacobsnAuthor Commented:
Adjusted points from 150 to 200
0
 
rjacobsnAuthor Commented:
I tried swapping the modem and the mouse.  The mouse continued to work fine, the modem was still undetected.  So now I'm trying to install the modem on Com2.

I made all the same checks on Com2, that is, in CMOS it is enabled and set to 2f8 irq3. The port in Control panel is set to the same.

Any other suggestions?

rjacobsn
0
 
vikiingCommented:
If BIOS allow both COM1 AND COM2 ports, you must disable one of them in order to allow an external modem in one of them.

Example: if you want to connect modem as a COM2 device, you must disable on-board COM2, so motherboard recognizes the modem at that address and shows no conflict with that.
0
 
PCGuruCommented:
Tend to agree with otta, the only other thing to suggest is to re-verify that the modem is actually working correctly. Go to another PC, preferrably with a known working modem and try yours, NT vs Linux is not an issue, you can even try it on a win9x PC. I have a feeling that you will find "lights on but no body home" with this modem. Everything you have said so far points to it being faulty.

Cheers,
Guru

>>vikiing>> Sorry man, that only applies to internal modems.
0
 
vikiingCommented:
>>vikiing>> Sorry man, that only applies to internal modems.

No, dear boy; if you have any serial device (be an internal, or external, or whatever you connect to a COM port), and it's configurable via jumpers, you must disable the port (in BIOS settings) you want to use in order to not generate a conflict.
0
 
PCGuruCommented:
>>viking>> A device "other than" a modem I will accept, if it occupies or requires its own IRQ, but DEFINATELY NOT qand externanl modem. Regardless of the fact that I have done several defence related training courses on COMMS DATA and RELEVANT DEVICES, I have been using modems with PC's since the late '80s and I have NEVER heard someone say THAT before!!!
0
 
vikiingCommented:
>>I have been using modems with PC's since the late '80s

Hehehe... I've started to deal with modems in 1974... :) :)


>>I have NEVER heard someone say THAT before!!!

Well; there's always a first time.
0
 
OttaCommented:
> COM1 AND COM2 ports, you must disable one of them in order to allow an external modem in one of them.

Change "external" to "internal", and only then will this statement become correct.
0
 
PCGuruCommented:
>>>Otta, thanks man, at least someone knows the difference ;-)

Guru
0
 
vikiingCommented:
Opps !! now I see; sorry if I wasn't clear enough.

0
 
rjacobsnAuthor Commented:
Hi again.  Sorry I had to take a break there.  Sick child at home.

I tried the modem on another computer and sure enough it wasn't working.  Since I was still suspicious of the cable I decided to give that one last try.  So I put the modem back on the linux box with a string of weird cables <a 25 pin male on both ends, followed by a 25 to 9 pin converter, followed by a 9 pin female on both ends, bunch of cables out of a box of cables,  in my experience these things rarely work but it was a last ditch effort.>  And, surprise, it worked.  It was the cable!

So back to the NT box and everything went very smoothly.

Thanks to everyone for thier help.

rjacobsn
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.