Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 191
  • Last Modified:

win95/98 network problems

i am getting 'error 254' when trying to load ipx protocol across a win95 to win98 pc network - cannot connect for ipx network games
0
jgrove
Asked:
jgrove
1 Solution
 
AdamWoodlandCommented:
Have you tried using TCP/IP? (If the game can support it).

Can you connect to each other's machine normaly through explorer?
0
 
RickWillkinsCommented:
These problems can occur when you choose to specify a value for Maximum Connections or Maximum Sockets on the Advanced tab in the IPX/SPX- Compatible Protocol Properties dialog box. If you specify a value that is lower than the normal default value, the problems described above may occur.

In Control Panel, double-click Network.


Click IPX/SPX-Compatible Protocol, and then click Properties.


Click the Advanced tab.


Click Maximum Connections in the Property box, and then click Not Present.


Click Maximum Sockets in the Property box, and then click Not Present.


Click OK.


Use Registry Editor to remove the Maxconnect and Maxsockets values in the following registry key:
      Hkey_Local_Machine\System\CurrentControlSet\Services\VxD\Nwlink



To modify the Maximum Connections and Maximum Sockets values so that they are equal to or greater than the default values, follow these steps:
In Control Panel, double-click Network.


Click IPX/SPX-Compatible Protocol, and then click Properties.


Click the Advanced tab.


Click Maximum Connections in the Property box, click Value, and then type a value of at least 16 in the Value box.


Click Maximum Sockets in the Property box, click Value, and then type a value of at least 32 in the Value box.


Click OK.


I know this is the case for win95, can only assume it would have the same problem for win98...

Best of luck,

Rick



0
 
alavanCommented:
We have an IPX print server and in order to get devices to talk to it, we have to set the Frame Type to Ethernet 802.3 in the IPX Network Settings.

Try that.

To get to your settings go to Control Panel, Network, then highlight IPX/SPX Compatible -> (your Ethernet card), then click the Properties button. Highlight the Frame Type setting and select "Ethernet 802.3".

Also, if you're connecting 2 machines together for the first time make sure you're either connecting them directly together using a cross-over CAT-5 patch cable or you're using a hub that indicates successful link via a light on each connected port. Also, make sure you have "link" lights on the 2 PC's.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now