[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 266
  • Last Modified:

"hdc: lost interrupt" messages during "glibc" package installation.

I have attempted to install each of Mandrake 7.0, Corel and Red Hat 6.2 and each has failed with similar errors.  In particular, when the application attempts to install the subject package I receive a long list of "lost interrupt" messages from which the installation is unable to recover.  My "hdc" is my CD-ROM which is a five year old Creative Labs module (actually, Goldstar CD-ROM GCD-R580B).  It has been assigned its own IDE and has been properly jumped as Master.  All other application within Win95 using this device proceed without error leading me to believe that the device is fully functional.  I have been unable to 100% prove that the device is fully supported however I would hop that such an ATAPI would be.  Finally, I have attempted to apply thei installation with both PnP enabled and disabled.
0
gbowles
Asked:
gbowles
1 Solution
 
jlevieCommented:
"Lost Interrupt" sounds like a hardware problem, either with the CD ROM drive or the MB. And no, just because win95 can "use it" doesn't mean that it's working correctly.

PnP should be disabled, if for no other reason than Linux doesn't use PnP and not all things work properly with PnP enabled. It has nothing to do with the IDE controllers and the attached drives.

If possible I'd suggest trying a different (and more up to date) CD drive. If the problem persists it'll be time to consider what the MB might be doing.
0
 
friebeleCommented:
Try this...RedHat allows you to install packages from a harddrive partition. From memory you need to create in your windows root directory a RedHat directory, with sub driectories i386 and base, as on your installation cd. Esentially copy these directories onto the hd. When the Redhat installation prompts where are the packages, say harddisk and select the approapriate partition. I tried this once before and it worked.
0
 
kiffneyCommented:
I recall seeing some patches for the goldstar cdrom popping up not that long ago on the kernel mailing list.  Look in google with 'linux kernel goldstar r580b' and see  if you can find them.  They might not have made it into the kernel tree and they might help.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
gbowlesAuthor Commented:
Thanks everyone for their comments as I attempted to find drivers etc.  However, it seems that the problem was directly related to the drive itself in that it is either not support or had some sort of problem that the LINUX installation was unable to resolve.  As suggeted I borrowed a Mitsubishi model off a buddy of mine and attempted the installation again and all associated errors disappeared.

Does anyone know if I can reapply this CD-ROM without fear now that the OS has been installed successfully?

Thanks again...

Greg
0
 
kiffneyCommented:
You can try it, but in all likelihood the driver that couldn't handle the goldstar is still going to have problems with the goldstar.  The driver used for the install is almost always the driver used in the actual system once set up.
0
 
jlevieCommented:
I agree with kiffney, if it didn't work for the install it won't work in the running system.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now